summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-01-12 15:07:01 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-01-12 15:07:01 +0100
commit895f48789ccd6f0e4fede232a858376c8683cdd0 (patch)
tree30ef6c42a0ae128ad7ee9ab5c78b1f1a776ca094 /dev-python
parentmedia-video/aegisub: remove old. (diff)
downloadgentoo-895f48789ccd6f0e4fede232a858376c8683cdd0.tar.gz
gentoo-895f48789ccd6f0e4fede232a858376c8683cdd0.tar.bz2
gentoo-895f48789ccd6f0e4fede232a858376c8683cdd0.zip
dev-python/docker-py: Version bump to 2.0.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-2.0.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index 9deefe81c485..4cceff1a5ebe 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -2,3 +2,4 @@ DIST docker-py-1.10.6.tar.gz 122462 SHA256 dd1aa55dbe507538318e51e5303077d146d51
DIST docker-py-1.2.2.tar.gz 69685 SHA256 85284a5b1a965e01a5d0a91f9f639ad5069143a276c123198fdafc3659280b38 SHA512 bf00b19e0ab56e5c0e8459234d09722ca504ecd933bfba61cb4ab4805410f53f6ad6083f2e964ef5a6eded2ea05aa01a89c27621064386bae145c7258ed996ad WHIRLPOOL bd7ff4579f924e02d18581b1aca00790dcb84afda03e4cde70b349bfdb4ad43aa2e06da2bcbe780f6074d98f9af9b14fb9d2ab4da9265e56b73288902c9ede7a
DIST docker-py-1.9.0.tar.gz 105939 SHA256 0ff58798c8cf79c7e459505786b3b83ca0552a077945b8fe20fc38ff3f732361 SHA512 49e6d4e8ab30c4e54165e7eff9e3034a1fe102348020bad2c5aefa238c44efdf39711536a7727fd9689e2e90483a348930bb91f1e76cade546161c82990f78ed WHIRLPOOL d60bca034f91569f37bef65ff42fcf950dfbc02bc42053bb650a9188661a8c0d9c21cb03128782a15799e6f208e88b32618286615ef94ba9396a4940ae3b6603
DIST docker-py-2.0.0.tar.gz 159296 SHA256 d567db615375df7655e2c4ac794b6a7c6a06c3437ee1ace476e04a88d94531c4 SHA512 773f8899bef8ac225a2d42b645b8a6f62485661fff1753bf91ab6653f8b81597ed3ea944b32e7ce106eec49215582671f4249e0569e28568559a09ca0905f58e WHIRLPOOL c2fb2686966845617b9450439060a90b0c4536c66b34aba07ae680959e842aaf9541b823505a4de81a2b8f17eb3380a578ba2802f9f80a699a3d539d85c0083a
+DIST docker-py-2.0.1.tar.gz 160820 SHA256 21b37d9fb581bcf88fe5e38ed915a7e3d4bd94174ec45f654669d970da371801 SHA512 097956bbf67659702cc92762f1570c5f86c478f38c527974b9f2f9938e9baa9a8c97f0c3b5252343a92f036e0712dc09cbbc1c1d7fa893b194cef9ec02b37c5a WHIRLPOOL f3451f6a9ded054cd977c57e06608f891ad933af464254243df5be9d909883b11451620aab21e3acb535acb7aec13c077b0e62c7683166c4b4f170812e3b8759
diff --git a/dev-python/docker-py/docker-py-2.0.1.ebuild b/dev-python/docker-py/docker-py-2.0.1.ebuild
new file mode 100644
index 000000000000..2fdf61fa754a
--- /dev/null
+++ b/dev-python/docker-py/docker-py-2.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test" # doc
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ )
+"
+# Doc require later sphinx version that is not packaged yet
+# doc? ( dev-python/recommonmark[${PYTHON_USEDEP}]
+# >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}] )
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+
+#python_compile_all() {
+ #if use doc; then
+ # sphinx-build docs html || die "docs failed to build"
+ #fi
+#}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ #use doc && local HTML_DOCS=( html/. )
+
+ distutils-r1_python_install_all
+}