summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-11-24 22:40:25 +0100
committerDavide Pesavento <pesa@gentoo.org>2017-11-24 22:40:25 +0100
commit89b42c280e31fd26504b94264b7f5c08ab255ff1 (patch)
tree65144a1873597e110ece8c41e041b32e96d44714 /dev-python
parentdev-python/PyQt5: version bump (diff)
downloadgentoo-89b42c280e31fd26504b94264b7f5c08ab255ff1.tar.gz
gentoo-89b42c280e31fd26504b94264b7f5c08ab255ff1.tar.bz2
gentoo-89b42c280e31fd26504b94264b7f5c08ab255ff1.zip
dev-python/PyQt5: remove old
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt5/Manifest1
-rw-r--r--dev-python/PyQt5/PyQt5-5.9.ebuild198
2 files changed, 0 insertions, 199 deletions
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
index 9ed393d1fef0..b1c6ff25209d 100644
--- a/dev-python/PyQt5/Manifest
+++ b/dev-python/PyQt5/Manifest
@@ -1,4 +1,3 @@
DIST PyQt5_gpl-5.7.1.tar.gz 3733746 SHA256 be849f212a074049b9ebc10b6c07dddefb86e6d30e8df8a5c715cbb2cf7fad14 SHA512 7498713f73807522e58ae38ff58548cf80c2f2c418d6c55e20ce613cdc997e4ee7139076f1f152c7c3edb970bde14febc3496009f934e31ff71f01a1605f558f WHIRLPOOL 9322ccaaebf78a9e177703bae26f002cdfe9ad3ba45a9c7b9ccdd3b73cca96550e479b243b302d59eefdc1520a6e5b5f18ac5fabc1f8eff36f7f76d71b7dea11
DIST PyQt5_gpl-5.9.1.tar.gz 3101819 BLAKE2B b457a101ad285e65cd246a7f77cc2d8a53b4b948d1b22405abf7f3a4ea7a0ab10335b310f1731c6660937fa18647fc00858b781f32d44dd85d1452d2eca821cf SHA512 1c7d00dac5329296dd205eddeeecfd29495c4746791730056d143438871eb64a5d9827dcb1e28a78e8746218908e0e72374bd686a21b631b9aa1aa1c67e61eac
DIST PyQt5_gpl-5.9.2.tar.gz 3102848 BLAKE2B b87f25693aa2b20211119f89cf13665bf88f14de8827d43ba757344ab9bdef0b0c197abb8386308c72925da263cabb6efd3f104db8a350c51fca3fba8c7c06b6 SHA512 5af2e65addaed7dd02d8dbf7a7c63767e565fc8edeb7b51e5991a00cda29f75b666529097646e821aaff556f350a929fd451f548bba76e97355b7fe10bd913bc
-DIST PyQt5_gpl-5.9.tar.gz 3097557 SHA256 ab0e7999cf202cc72962c78aefe461d16497b3c1a8282ab966ad90b6cb271096 SHA512 6e925dee751d6b2ab97b3614b0150f305798b89920e11db7a2cbef579e4c21839a38f4ad7eee5828a0c28942999955715a265e043004ee7838d376025d32e4aa WHIRLPOOL b92833ecc97638c8dac5e35de155ddb9d5783925aa8ab50bdd823b793675354b37edc29e17396241de87b25ae142c37a9cd1c215ad57c25b928ec0af3deac8aa
diff --git a/dev-python/PyQt5/PyQt5-5.9.ebuild b/dev-python/PyQt5/PyQt5-5.9.ebuild
deleted file mode 100644
index de9e668e6d1f..000000000000
--- a/dev-python/PyQt5/PyQt5-5.9.ebuild
+++ /dev/null
@@ -1,198 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit multibuild python-r1 qmake-utils
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"
-
-MY_P=${PN}_gpl-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
-else
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-# TODO: QtNfc
-IUSE="bluetooth dbus debug declarative designer examples gles2 gui help location
- multimedia network opengl positioning printsupport sensors serialport sql svg
- testlib webchannel webengine webkit websockets widgets x11extras xmlpatterns"
-
-# The requirements below were extracted from configure.py
-# and from the output of 'grep -r "%Import " "${S}"/sip'
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- bluetooth? ( gui )
- declarative? ( gui network )
- designer? ( widgets )
- help? ( gui widgets )
- location? ( positioning )
- multimedia? ( gui network )
- opengl? ( gui widgets )
- positioning? ( gui )
- printsupport? ( gui widgets )
- sensors? ( gui )
- serialport? ( gui )
- sql? ( widgets )
- svg? ( gui widgets )
- testlib? ( gui widgets )
- webchannel? ( network )
- webengine? ( network widgets? ( webchannel ) )
- webkit? ( gui network printsupport widgets )
- websockets? ( network )
- widgets? ( gui )
- xmlpatterns? ( network )
-"
-
-# Minimal supported version of Qt.
-QT_PV="5.6.0:5"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=dev-python/sip-4.19.3:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- >=dev-qt/qtxml-${QT_PV}
- bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2=] )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- location? ( >=dev-qt/qtlocation-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
- network? ( >=dev-qt/qtnetwork-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets?] )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV}[printsupport] )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
- widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
- x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-DOCS=( "${S}"/{ChangeLog,NEWS} )
-
-pyqt_use_enable() {
- use "$1" || return
-
- if [[ $# -eq 1 ]]; then
- echo --enable=Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}
- else
- shift
- echo ${@/#/--enable=}
- fi
-}
-
-src_configure() {
- configuration() {
- # Fix out-of-source build
- ln -s "${S}"/config-tests || die
-
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- $(usex debug '--debug --qml-debug --trace' '')
- --verbose
- --confirm-license
- --qmake="$(qt5_get_bindir)"/qmake
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --sip-incdir="$(python_get_includedir)"
- --qsci-api
- --enable=QtCore
- --enable=QtXml
- $(pyqt_use_enable bluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(usex dbus '' --no-python-dbus)
- $(pyqt_use_enable declarative QtQml QtQuick $(usex widgets QtQuickWidgets ''))
- $(usex declarative '' --no-qml-plugin)
- $(pyqt_use_enable designer)
- $(usex designer '' --no-designer-plugin)
- $(pyqt_use_enable gui)
- $(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
- $(pyqt_use_enable help)
- $(pyqt_use_enable location)
- $(pyqt_use_enable multimedia QtMultimedia $(usex widgets QtMultimediaWidgets ''))
- $(pyqt_use_enable network)
- $(pyqt_use_enable opengl QtOpenGL)
- $(pyqt_use_enable positioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable sensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable sql)
- $(pyqt_use_enable svg)
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable webengine QtWebEngineCore $(usex widgets QtWebEngineWidgets ''))
- $(pyqt_use_enable webkit QtWebKit QtWebKitWidgets)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets)
- $(pyqt_use_enable x11extras QtX11Extras)
- $(pyqt_use_enable xmlpatterns QtXmlPatterns)
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- eqmake5 -recursive ${PN}.pro
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- local tmp_root=${D%/}/tmp
- emake INSTALL_ROOT="${tmp_root}" install
-
- local bin_dir=${tmp_root}${EPREFIX}/usr/bin
- local exe
- for exe in pylupdate5 pyrcc5 pyuic5; do
- python_doexe "${bin_dir}/${exe}"
- rm "${bin_dir}/${exe}" || die
- done
-
- local uic_dir=${tmp_root}$(python_get_sitedir)/${PN}/uic
- if python_is_python3; then
- rm -r "${uic_dir}"/port_v2 || die
- else
- rm -r "${uic_dir}"/port_v3 || die
- fi
-
- multibuild_merge_root "${tmp_root}" "${D}"
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}