summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-27 10:37:03 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-28 16:19:30 +0200
commit89c78543a0a0a229013bd3d565857589ef785cce (patch)
tree8ff508fcb74d5126742c881e48be393a5e626d73 /dev-python
parentdev-python/pylru: bump python 3.{9,10}, add tests (diff)
downloadgentoo-89c78543a0a0a229013bd3d565857589ef785cce.tar.gz
gentoo-89c78543a0a0a229013bd3d565857589ef785cce.tar.bz2
gentoo-89c78543a0a0a229013bd3d565857589ef785cce.zip
dev-python/pyformance: bump python 3.{9,10}
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21004 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyformance/pyformance-0.4-r1.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/pyformance/pyformance-0.4-r1.ebuild b/dev-python/pyformance/pyformance-0.4-r1.ebuild
index de8932038a89..00c24dde4952 100644
--- a/dev-python/pyformance/pyformance-0.4-r1.ebuild
+++ b/dev-python/pyformance/pyformance-0.4-r1.ebuild
@@ -1,32 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
+
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~chutzpah/dist/python/pyformance-0.4-patches.tar.xz"
+ https://dev.gentoo.org/~chutzpah/dist/python/${P}-patches.tar.xz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
test? ( dev-python/mock[${PYTHON_USEDEP}] )
"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
distutils_enable_tests pytest
PATCHES=(
- "${WORKDIR}/pyformance-0.4-patches"
+ "${WORKDIR}/${P}-patches"
)
python_prepare() {