summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-24 05:08:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-24 05:08:33 +0200
commit8c87a67daf80f53f4a393e9aaa76f5042909f61e (patch)
treeb9776be4b8c2a3276490cfad63ec68c555f60112 /dev-python
parentdev-python/python-lsp-jsonrpc: Bump to 1.1.2 (diff)
downloadgentoo-8c87a67daf80f53f4a393e9aaa76f5042909f61e.tar.gz
gentoo-8c87a67daf80f53f4a393e9aaa76f5042909f61e.tar.bz2
gentoo-8c87a67daf80f53f4a393e9aaa76f5042909f61e.zip
dev-python/astroid: Bump to 2.15.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.15.7.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 75a449ba13c4..abe3e6d51e53 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1 +1,2 @@
DIST astroid-2.15.6.gh.tar.gz 462156 BLAKE2B f5df204a0b635d29165da1566afd9259ff26102fef3b56685ad9e10fe1cdae35aa90b1e1f81293e591c03122e980936dfd91b521dfe7a4c8cfacb8b40bcac9d6 SHA512 20c4d316176b84d61b5f44823026926e84c7de3c3a6febaa23cf9c8c5a9507ce65168804a61cb2db0ffcc7ec0ecb687282e6c794485135203cc25d30064e0047
+DIST astroid-2.15.7.gh.tar.gz 462906 BLAKE2B 7a984f9f7c67c2956958b23ee2ca94c1f86284d8a50aaedbe10b9dca887802189cba21f19ee66b394f347f415d61946aaff52e4d0448271edba77b6bd958fa0e SHA512 716665744915d8a635ac124f03ffe6f7aee6bde6d98c238551ea1c6468595d6c327bb2d5605f66e7ba6294ec1b79c85b861034acba8a4584095ba38e24f82ae9
diff --git a/dev-python/astroid/astroid-2.15.7.ebuild b/dev-python/astroid/astroid-2.15.7.ebuild
new file mode 100644
index 000000000000..d2feb47f4808
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ # requires pip, and looks suspicious anyway
+ tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
+ # pydantic-2?
+ tests/brain/test_dataclasses.py::test_pydantic_field
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}