summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-08-24 17:48:28 +0200
committerMarek Szuba <marecki@gentoo.org>2020-08-24 19:07:43 +0200
commit8d143bf03864b557494529e2fc6d5b74af60c6d4 (patch)
treeccd0f78686f23d41d77fcef1539e9b3a06e1db95 /dev-python
parentdev-python/pytools: bump to 2020.4 (diff)
downloadgentoo-8d143bf03864b557494529e2fc6d5b74af60c6d4.tar.gz
gentoo-8d143bf03864b557494529e2fc6d5b74af60c6d4.tar.bz2
gentoo-8d143bf03864b557494529e2fc6d5b74af60c6d4.zip
dev-python/pyopencl: bump to 2020.2.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2020.2.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index f76541884d8c..96d717e5f9c1 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1 +1,2 @@
+DIST pyopencl-2020.2.1.tar.gz 352160 BLAKE2B 2258c050bb8b279e3bcf563d805e36032d2f74c6b960e1453608ba1bbcf9b677c056eca5f5dde73ab2a45c13dd4653715682d83251954ee0aa841f4b65461d92 SHA512 5d74c61ec56c9893f8419e386e4ea16f3e1d20a922e0d7de6bf167fcd54cfac1715289bbf41af793f73c66e9738f63cd2f4a705d5addfd2e3ae2373ff3ed4866
DIST pyopencl-2020.2.tar.gz 351600 BLAKE2B 47a733d7a552f5d1f69a1a9710c3262d50c26651ed9f46146829babe28962e236e2c1b9ba3d3d14207f28bdc562323a94ab4c51dbf5fcf1a0b12282b3c6aff50 SHA512 233bbf2e99507d3a832222cc8149bf7ac17332a550e4867f843fcc2b31104d961a3f0d972b0a1878d4716b2da4548f1390560141cd09cb1ba13300c541b058b9
diff --git a/dev-python/pyopencl/pyopencl-2020.2.1.ebuild b/dev-python/pyopencl/pyopencl-2020.2.1.ebuild
new file mode 100644
index 000000000000..e5fbb9b9f447
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2020.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+COMMON="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+DEPEND="${COMMON}
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}