summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-10 16:49:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-10 16:49:48 +0100
commit8d9db39d18786ea82091591c510cd0835a119bc9 (patch)
tree552118e4aab204d6ab6e2761008ff5842c075acf /dev-python
parentdev-python/pytest-salt-factories: Remove old (diff)
downloadgentoo-8d9db39d18786ea82091591c510cd0835a119bc9.tar.gz
gentoo-8d9db39d18786ea82091591c510cd0835a119bc9.tar.bz2
gentoo-8d9db39d18786ea82091591c510cd0835a119bc9.zip
dev-python/pytest-system-statistics: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-system-statistics/Manifest1
-rw-r--r--dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pytest-system-statistics/Manifest b/dev-python/pytest-system-statistics/Manifest
index 1cd15b29538a..dceabab2f895 100644
--- a/dev-python/pytest-system-statistics/Manifest
+++ b/dev-python/pytest-system-statistics/Manifest
@@ -1,2 +1 @@
DIST pytest-system-statistics-1.0.2.gh.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
-DIST pytest-system-statistics-1.0.2.tar.gz 55147 BLAKE2B 9b1217102a23e723090e04652fdd727818e2404bf110e4f54289251eb92f4abb59861ba6c6fc611c843960cf0595fa5cbd636071033327d4e602606e8ab63abf SHA512 1fab5038dde504ab0d5d0f4da851c9a8260849adb38a1196c6399131d77cc24a1926e68310dd0701ed001a20a7fcfb57c5202c5ebfd6de4c85aac4be49fc7347
diff --git a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild b/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
deleted file mode 100644
index cfad9b945e60..000000000000
--- a/dev-python/pytest-system-statistics/pytest-system-statistics-1.0.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Pytest Plugin Which Reports System Usage Statistics"
-HOMEPAGE="
- https://pypi.org/project/pytest-system-statistics/
- https://github.com/saltstack/pytest-system-statistics
-"
-SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/wheel[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
- sed -e "/setuptools_scm/ d" -i setup.cfg || die
- sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
-
- printf '__version__ = "${PV}"\n' > src/pytestsysstats/version.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest -k 'not proc_sys_stats'
-}