summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-01-16 13:44:54 +0100
committerSam James <sam@gentoo.org>2022-04-05 04:24:13 +0100
commit8dd3ba1c703e1682b017c5f59283f194c6bbb626 (patch)
treeb27eb1cbb7c3160c141aae650c389064960a1a04 /dev-python
parentdev-python/python-ptrace: style tweaks; PEP517; fix Manifest (diff)
downloadgentoo-8dd3ba1c703e1682b017c5f59283f194c6bbb626.tar.gz
gentoo-8dd3ba1c703e1682b017c5f59283f194c6bbb626.tar.bz2
gentoo-8dd3ba1c703e1682b017c5f59283f194c6bbb626.zip
dev-python/pefile: new ebuild
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pefile/Manifest1
-rw-r--r--dev-python/pefile/metadata.xml21
-rw-r--r--dev-python/pefile/pefile-2021.9.3.ebuild29
-rw-r--r--dev-python/pefile/pefile-9999.ebuild29
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/pefile/Manifest b/dev-python/pefile/Manifest
new file mode 100644
index 000000000000..6ff3f1165f40
--- /dev/null
+++ b/dev-python/pefile/Manifest
@@ -0,0 +1 @@
+DIST pefile-2021.9.3.tar.gz 72179 BLAKE2B a1b5390936e6c307b1d7d30f317ae77b432b17300941bfe71c4c8ed9dfecf95d623ce98eb762378ee1ff7ae938e4105e4dbcb2f6b8fe32c502b725c43b3a1154 SHA512 1960a6301823387c76e61dff73250686a32dabe009ff0410691ab9be4e57fd5f7ceca2b78302c935b74465a1e0b8faac659045c8a2be07b21dcf1baf510b1b33
diff --git a/dev-python/pefile/metadata.xml b/dev-python/pefile/metadata.xml
new file mode 100644
index 000000000000..53ac969c885d
--- /dev/null
+++ b/dev-python/pefile/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ pefile is a multi-platform Python module to parse and work with
+ Portable Executable (PE) files. Most of the information contained in
+ the PE file headers is accessible, as well as all the sections' details
+ and data.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">erocarrera/pefile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pefile/pefile-2021.9.3.ebuild b/dev-python/pefile/pefile-2021.9.3.ebuild
new file mode 100644
index 000000000000..84c6fed76927
--- /dev/null
+++ b/dev-python/pefile/pefile-2021.9.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.
diff --git a/dev-python/pefile/pefile-9999.ebuild b/dev-python/pefile/pefile-9999.ebuild
new file mode 100644
index 000000000000..84c6fed76927
--- /dev/null
+++ b/dev-python/pefile/pefile-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/future[${PYTHON_USEDEP}]"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.