summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-31 09:42:30 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-31 09:42:30 +0100
commit8e7c8884b3dd912269310d1570d400f24fafba2b (patch)
tree32125ed4abb9cbf45db55cfc7a1874a50483ba05 /dev-python
parentdev-python/portend: Remove old (diff)
downloadgentoo-8e7c8884b3dd912269310d1570d400f24fafba2b.tar.gz
gentoo-8e7c8884b3dd912269310d1570d400f24fafba2b.tar.bz2
gentoo-8e7c8884b3dd912269310d1570d400f24fafba2b.zip
dev-python/packaging: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/packaging/Manifest2
-rw-r--r--dev-python/packaging/files/packaging-16.8-distutils.patch14
-rw-r--r--dev-python/packaging/packaging-20.4-r1.ebuild51
-rw-r--r--dev-python/packaging/packaging-20.5.ebuild37
4 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 9056064ad0ad..2dfc74497551 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,4 +1,2 @@
-DIST packaging-20.4.tar.gz 74402 BLAKE2B 3c667c1605445aec37d264ec3846a1a6678f13a12aecc09a6d16e09ea27041fcd65d23538acef4f6272ab0458ce479c42906b15cb6eddd9c8001b1970c23e4fc SHA512 d53912041a9950efb5d221fc968adc328c2ef1e54ec9806d2158fd6db1b170e37afb05213f5750b10c59927504083ca3781c958caa0c802b1c7c0fe1ac1682a4
-DIST packaging-20.5.gh.tar.gz 75111 BLAKE2B b088b85fc042b48337878c0f663934f32f90eb792ba53257b1b0879a097ef042b67a9cff56b23f5e0187a3df0f89092e0210939382851f0ae917f6ef00ad73ff SHA512 ef3c4853c30d9635b9372d6861cc0df8f7fc5a1d784e5f3effe3f315da0f24662ac939e70f55c6e9bb8864da95b9f75bc0df093f12c0f5c2af654b5354a5f081
DIST packaging-20.7.gh.tar.gz 75182 BLAKE2B f3ba27ec33db576273609f28aabb5edab4acd07d8174c96e3a1608eacdc1a571d2ce96cc4e38c50c964ae5a716bbca077effd6dea039b25ac7bd6ce5707ae08b SHA512 4da8f66af066ac92b47664d21af34a02526cd1639cb766927670bec0ac8c7416116834c847678a29862a46faeda7e2f2393744be315cdfbbb8bd55a04ceb942c
DIST packaging-20.8.gh.tar.gz 76310 BLAKE2B f6a220bf8ed61e4ced5cdb93eac8a83310d5c1abc11861e3eca64ef08e3fa2617a9dedd9006fd833df37da5bd7a33c216fb78b9151b1c72121fbb0a27e7b88d3 SHA512 77c77da9298635274de58b856b8738ab279749f736264212e6ecdeab47db607ea9c6ae696952f0702e9557d1fd2b89c7277a2c81ff55081593f49ebcd6eb74d4
diff --git a/dev-python/packaging/files/packaging-16.8-distutils.patch b/dev-python/packaging/files/packaging-16.8-distutils.patch
deleted file mode 100644
index 84bbb618a6fe..000000000000
--- a/dev-python/packaging/files/packaging-16.8-distutils.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -13,10 +13,7 @@ import re
- # dependency when projects attempt to unbundle stuff from setuptools and pip.
- # Though we don't really support that, it makes things easier if we do this and
- # should hopefully cause less issues for end users.
--try:
-- from setuptools import setup
--except ImportError:
-- from distutils.core import setup
-+from distutils.core import setup
-
-
- base_dir = os.path.dirname(__file__)
diff --git a/dev-python/packaging/packaging-20.4-r1.ebuild b/dev-python/packaging/packaging-20.4-r1.ebuild
deleted file mode 100644
index aa07f75b23b0..000000000000
--- a/dev-python/packaging/packaging-20.4-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-16.8-distutils.patch"
-)
-
-python_test() {
- pytest --capture=no --strict -vv || die
-}
-
-pkg_preinst() {
- # https://bugs.gentoo.org/585146
- cd "${HOME}" || die
-
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- rm -rv "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- python_foreach_impl _cleanup
-}
diff --git a/dev-python/packaging/packaging-20.5.ebuild b/dev-python/packaging/packaging-20.5.ebuild
deleted file mode 100644
index f47993e248b0..000000000000
--- a/dev-python/packaging/packaging-20.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="
- https://github.com/pypa/packaging/
- https://pypi.org/project/packaging/"
-SRC_URI="
- https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- pytest --capture=no --strict -vv || die
-}