summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-23 13:15:47 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-23 18:34:15 +0200
commit8ee9fecf8d5200cbd27da342a808b1841c9826c7 (patch)
treead00018095d5e26da840835d5db35f2014b570ce /dev-python
parentdev-python/hypothesis: Bump to 6.13.2 (diff)
downloadgentoo-8ee9fecf8d5200cbd27da342a808b1841c9826c7.tar.gz
gentoo-8ee9fecf8d5200cbd27da342a808b1841c9826c7.tar.bz2
gentoo-8ee9fecf8d5200cbd27da342a808b1841c9826c7.zip
dev-python/pdfrw: bump to python 3.9
passes tests Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pdfrw/pdfrw-0.4_p1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/pdfrw/pdfrw-0.4_p1.ebuild b/dev-python/pdfrw/pdfrw-0.4_p1.ebuild
index 43e32b1d00f4..bdb7083b77ae 100644
--- a/dev-python/pdfrw/pdfrw-0.4_p1.ebuild
+++ b/dev-python/pdfrw/pdfrw-0.4_p1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
@@ -27,14 +27,11 @@ fi
LICENSE="BSD MIT"
SLOT="0"
-IUSE="crypt test"
+IUSE="crypt"
BDEPEND="dev-python/pillow[${PYTHON_USEDEP}]
crypt? ( dev-python/pycryptodome[${PYTHON_USEDEP}] )
- test? ( dev-python/reportlab[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )"
-
-RESTRICT="!test? ( test )"
+ test? ( dev-python/reportlab[${PYTHON_USEDEP}] )"
# unittest would be sufficient but its output is unreadable
distutils_enable_tests pytest