summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 12:36:05 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 12:36:05 +0100
commit8f6782782c99053ae3449d2a3f8266b3fe12c63a (patch)
tree310adc42f008a446e5c9405429ba47879cfedb10 /dev-python
parentdev-python/google-api-core: Remove old (diff)
downloadgentoo-8f6782782c99053ae3449d2a3f8266b3fe12c63a.tar.gz
gentoo-8f6782782c99053ae3449d2a3f8266b3fe12c63a.tar.bz2
gentoo-8f6782782c99053ae3449d2a3f8266b3fe12c63a.zip
dev-python/owslib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.29.2.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 20a16cdee261..04b2be6cd3b3 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1,2 +1 @@
-DIST OWSLib-0.29.2.gh.tar.gz 953216 BLAKE2B 3c0204cd62fdf3fe36ca2051a83a00ad165e7f7682d850c3796877c83382f7a3c68d2c02f8dfaa90016909393a9bfd6f2415499f6096de9f4333102b20ccd932 SHA512 66c0c6b4bcae08f0acbf1d4ee4a0e5d2b33996ae0d088ddd01844f050da364c581f7ea2a46d48652b969c75e8b31caf4c721f497ea079fb779d670199dd56746
DIST OWSLib-0.29.3.gh.tar.gz 994453 BLAKE2B 442dc832b94bfdc383b9d932de957696f9abb4d3843c856b07cf56a47c42291c6d7ff8b8713bb123d296c780e44efbfa08ba94ba2ee747dc7a2f4de0508a5f0f SHA512 2aa63ae18830d724f2cb46647ed867c5b74b2858a93df2500160b5cd58b25b0fb39bfc2d5bcda58bfe3b229bac5ea68acf9abdc746971e2eb5198875f00e6f4d
diff --git a/dev-python/owslib/owslib-0.29.2.ebuild b/dev-python/owslib/owslib-0.29.2.ebuild
deleted file mode 100644
index b0d7b8f21714..000000000000
--- a/dev-python/owslib/owslib-0.29.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-MY_P=OWSLib-${PV}
-DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
-HOMEPAGE="
- https://geopython.github.io/OWSLib/
- https://github.com/geopython/owslib/
- https://pypi.org/project/OWSLib/
-"
-SRC_URI="
- https://github.com/geopython/${PN}/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-RESTRICT="test"
-PROPERTIES="test_network"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # connection errors
- tests/test_wfs_generic.py::test_xmlfilter_wfs_110
- tests/test_wfs_generic.py::test_xmlfilter_wfs_200
- tests/test_ogcapi_records_pycsw.py::test_ogcapi_records_pycsw
- tests/test_opensearch_pycsw.py::test_opensearch_creodias
- tests/test_ows_interfaces.py::test_ows_interfaces_csw
- tests/test_csw3_pycsw.py::test_csw_pycsw
- tests/test_csw_pycsw.py::test_csw_pycsw
- tests/test_csw_pycsw_skip_caps.py::test_csw_pycsw_skip_caps
- # different output from remote service, sigh
- tests/test_ogcapi_processes_pygeoapi.py::test_ogcapi_processes_pygeoapi
-)
-
-python_test() {
- epytest -o addopts=
-}