summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-02 12:17:25 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-02 12:17:25 +0300
commit8f8649a73e141eaff8e3f7ee5a005e4d4d3e4750 (patch)
treefe5934234039f0223c113606ea2ec4710317dc85 /dev-python
parentdev-python/pypy: remove libressl support (diff)
downloadgentoo-8f8649a73e141eaff8e3f7ee5a005e4d4d3e4750.tar.gz
gentoo-8f8649a73e141eaff8e3f7ee5a005e4d4d3e4750.tar.bz2
gentoo-8f8649a73e141eaff8e3f7ee5a005e4d4d3e4750.zip
dev-python/pypy3: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3/pypy3-7.3.3_p37_p1-r1.ebuild5
-rw-r--r--dev-python/pypy3/pypy3-7.3.3_p37_p3.ebuild5
-rw-r--r--dev-python/pypy3/pypy3-7.3.4.ebuild5
-rw-r--r--dev-python/pypy3/pypy3-7.3.4_p1.ebuild5
4 files changed, 8 insertions, 12 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.3_p37_p1-r1.ebuild b/dev-python/pypy3/pypy3-7.3.3_p37_p1-r1.ebuild
index 5bf04f0ffd9f..6d392c9cbdaf 100644
--- a/dev-python/pypy3/pypy3-7.3.3_p37_p1-r1.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.3_p37_p1-r1.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
# also check pypy/interpreter/pycode.py -> pypy_incremental_magic
SLOT="0/pypy37-pp73"
KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 gdbm +jit libressl ncurses sqlite test tk"
+IUSE="bzip2 gdbm +jit ncurses sqlite test tk"
# pypy3.7 is in alpha state and a lot of tests are failing
RESTRICT="test"
@@ -30,8 +30,7 @@ RDEPEND="
>=dev-python/pypy3-exe-${PV}:${PV%_p*}[bzip2?,ncurses?]
>=dev-python/pypy3-exe-bin-${PV}:${PV%_p*}
)
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
gdbm? ( sys-libs/gdbm:0= )
sqlite? ( dev-db/sqlite:3= )
tk? (
diff --git a/dev-python/pypy3/pypy3-7.3.3_p37_p3.ebuild b/dev-python/pypy3/pypy3-7.3.3_p37_p3.ebuild
index 8c3717e04b85..f3f0a7435433 100644
--- a/dev-python/pypy3/pypy3-7.3.3_p37_p3.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.3_p37_p3.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
# also check pypy/interpreter/pycode.py -> pypy_incremental_magic
SLOT="0/pypy37-pp73"
KEYWORDS="amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 gdbm +jit libressl ncurses sqlite test tk"
+IUSE="bzip2 gdbm +jit ncurses sqlite test tk"
# pypy3.7 is in alpha state and a lot of tests are failing
RESTRICT="test"
@@ -30,8 +30,7 @@ RDEPEND="
>=dev-python/pypy3-exe-7.3.3_p37_p2:${PV%_p*}[bzip2?,ncurses?]
>=dev-python/pypy3-exe-bin-7.3.3_p37_p2:${PV%_p*}
)
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
gdbm? ( sys-libs/gdbm:0= )
sqlite? ( dev-db/sqlite:3= )
tk? (
diff --git a/dev-python/pypy3/pypy3-7.3.4.ebuild b/dev-python/pypy3/pypy3-7.3.4.ebuild
index d148519f71de..7c278dc39c19 100644
--- a/dev-python/pypy3/pypy3-7.3.4.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.4.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
# also check pypy/interpreter/pycode.py -> pypy_incremental_magic
SLOT="0/pypy37-pp73"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 gdbm +jit libressl ncurses sqlite test tk"
+IUSE="bzip2 gdbm +jit ncurses sqlite test tk"
# pypy3.7 is in alpha state and a lot of tests are failing
RESTRICT="test"
@@ -30,8 +30,7 @@ RDEPEND="
>=dev-python/pypy3-exe-${PV}:${PV%_p*}[bzip2?,ncurses?]
>=dev-python/pypy3-exe-bin-${PV}:${PV%_p*}
)
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
gdbm? ( sys-libs/gdbm:0= )
sqlite? ( dev-db/sqlite:3= )
tk? (
diff --git a/dev-python/pypy3/pypy3-7.3.4_p1.ebuild b/dev-python/pypy3/pypy3-7.3.4_p1.ebuild
index 0b16aad31cf4..7e7ed8f9cc20 100644
--- a/dev-python/pypy3/pypy3-7.3.4_p1.ebuild
+++ b/dev-python/pypy3/pypy3-7.3.4_p1.ebuild
@@ -21,7 +21,7 @@ LICENSE="MIT"
# also check pypy/interpreter/pycode.py -> pypy_incremental_magic
SLOT="0/pypy37-pp73"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 gdbm +jit libressl ncurses sqlite test tk"
+IUSE="bzip2 gdbm +jit ncurses sqlite test tk"
# pypy3.7 is in alpha state and a lot of tests are failing
RESTRICT="test"
@@ -30,8 +30,7 @@ RDEPEND="
>=dev-python/pypy3-exe-${PYPY_PV}:${PYPY_PV}[bzip2?,ncurses?]
>=dev-python/pypy3-exe-bin-${PYPY_PV}:${PYPY_PV}
)
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
gdbm? ( sys-libs/gdbm:0= )
sqlite? ( dev-db/sqlite:3= )
tk? (