summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 09:07:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 09:08:53 +0200
commit908ffca2ab1f340c2ff245842d12435b020aeb0b (patch)
tree63f77bc82af61019156fe323cf74d7dc7e245e00 /dev-python
parentdev-python/typeguard: Stabilize 4.1.4 ppc64, #914957 (diff)
downloadgentoo-908ffca2ab1f340c2ff245842d12435b020aeb0b.tar.gz
gentoo-908ffca2ab1f340c2ff245842d12435b020aeb0b.tar.bz2
gentoo-908ffca2ab1f340c2ff245842d12435b020aeb0b.zip
dev-python/dask: Use pytest-xdist!
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dask/dask-2023.9.3.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/dask/dask-2023.9.3.ebuild b/dev-python/dask/dask-2023.9.3.ebuild
index 7e6a97864b43..532c80da9d4b 100644
--- a/dev-python/dask/dask-2023.9.3.ebuild
+++ b/dev-python/dask/dask-2023.9.3.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
HOMEPAGE="
@@ -42,6 +42,7 @@ BDEPEND="
dev-python/moto[${PYTHON_USEDEP}]
dev-python/numexpr[${PYTHON_USEDEP}]
dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
)
"
@@ -81,5 +82,6 @@ python_test() {
fi
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_rerunfailures -m "not network"
+ epytest -p pytest_rerunfailures -m "not network" \
+ -p xdist -n "$(makeopts_jobs)"
}