summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-12-18 11:47:05 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-12-18 11:47:05 +0700
commit9204984143fe4b4f9439118c410d59586d068dbc (patch)
treea7e1e8d6f78ff8584ec84e99175baebbb99ba982 /dev-python
parentdev-util/pycharm-community: bump to 2016.3.1 (diff)
downloadgentoo-9204984143fe4b4f9439118c410d59586d068dbc.tar.gz
gentoo-9204984143fe4b4f9439118c410d59586d068dbc.tar.bz2
gentoo-9204984143fe4b4f9439118c410d59586d068dbc.zip
dev-python/spyder: install spyder2 and spyder3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spyder/spyder-3.0.2-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/spyder/spyder-3.0.2-r1.ebuild b/dev-python/spyder/spyder-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..fd3d8d914f21
--- /dev/null
+++ b/dev-python/spyder/spyder-3.0.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="https://github.com/spyder-ide/spyder/ https://pypi.python.org/pypi/spyder/ http://pythonhosted.org/spyder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc hdf5"
+
+RDEPEND="
+ || ( dev-python/PyQt5[${PYTHON_USEDEP},svg,webkit]
+ dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
+ dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
+ dev-python/QtPy[${PYTHON_USEDEP},svg,webkit]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/rope_py3k[${PYTHON_USEDEP}]' python3_4 python3_5)
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+# Courtesy of Arfrever
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc doc/html || die "Generation of documentation failed"
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+ doicon spyder/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+}