summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:31:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 11:41:03 +0200
commit953579380cadc46f46a3e65e22c3e36006cf79d1 (patch)
tree045ac7edb99fe712298da8e5b327aae486864f0c /dev-python
parentdev-python/botocore: Bump to 1.27.86 (diff)
downloadgentoo-953579380cadc46f46a3e65e22c3e36006cf79d1.tar.gz
gentoo-953579380cadc46f46a3e65e22c3e36006cf79d1.tar.bz2
gentoo-953579380cadc46f46a3e65e22c3e36006cf79d1.zip
dev-python/boto3: Bump to 1.24.86
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.86.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8306d890538c..d86fa772ca03 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.24.80.gh.tar.gz 539716 BLAKE2B ccbbfa84e4e2274eb0275b9b2dcc0a4a78b1
DIST boto3-1.24.81.gh.tar.gz 540005 BLAKE2B 7c0425351aaa4ee854d6cb616880b653250475051f3a295686659f3c85b6c515b6e622af72f6e56f69ff23be4e4218f74cbe48f6377f0d17d321f1521ed1fe8f SHA512 a92a4d90254ecc5dd098d22c9628cf87e5d5341c7aaf8b704fbe6f6e693b7582b65179936a6745da4b14a629fb20d39b501748349e3a8640eb54f9298493f287
DIST boto3-1.24.82.gh.tar.gz 540506 BLAKE2B 5b9c008309e7bc5ff0b79a2431d1b49c353895e698227a19557ffa56950d51b1743e096a09440d3cae94b55eada1a71e01664b3458991d5665e9678cd97fdd80 SHA512 bd1ab62bd9b4f5f641a0baf6fda8d99e2a60d1fbf1bcb670b76a8171987812feb1067964dae1b633b0e35202330f97525c1ed5bf169289b8bcdde18eb882853d
DIST boto3-1.24.84.gh.tar.gz 542495 BLAKE2B dc120011d9e7b01beeb86d90a88f69cc232d3ac1147d4764493359aab2a4b8a5344521e29961bd6f1a6bb27a38499c83f70dd2222d324dd1283601d8bc6a26f1 SHA512 bcba6880baccff46d96c76bc596a3dfbf6f595674097604bd3b58ece68ce75448c38677c1625e8615e0eb5796b7bcc2266a78da42d7ccee1be2ee182791ca980
+DIST boto3-1.24.86.gh.tar.gz 543481 BLAKE2B 8b21852f75c4c548dc2389f5d95145b1781a7b19fe5d12fd6a352e298a3e8e4301c9b9b84c2700d8a5b1f58c4343341370c9c88ce2fcae90a3310729cd8bdf19 SHA512 a50bf8601fe479094e2868c6da43f5a6510dca6f99c74920bc7c6629cd083fbabc80e650a3baabe2f749f1dd906bc6aab73042cd269bcbb4bc8072d72707b26a
diff --git a/dev-python/boto3/boto3-1.24.86.ebuild b/dev-python/boto3/boto3-1.24.86.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.86.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}