summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-28 18:39:25 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-28 23:48:04 +0200
commit95f24cca2723012d25589febc993a7a45f030e1f (patch)
tree9e1472cf5a97a01e584f22881ca15f03588a0661 /dev-python
parentdev-lua/penlight: drop old version (diff)
downloadgentoo-95f24cca2723012d25589febc993a7a45f030e1f.tar.gz
gentoo-95f24cca2723012d25589febc993a7a45f030e1f.tar.bz2
gentoo-95f24cca2723012d25589febc993a7a45f030e1f.zip
dev-python/sphinxcontrib-asyncio: EAPI=7, fix sphinx >= 4.0
- fix for `dev-python/sphinx` >= 4.0. Now successfully generates self docs - bump to `EAPI=7` - use `distutils_enable_sphinx` for docs - bump to python 3.9 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
index 1fd703331894..7b80ce7fde63 100644
--- a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="sphinx extension to support coroutines in markup"
@@ -13,17 +13,18 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
-python_compile_all() {
- use doc && emake -C docs html
+distutils_enable_sphinx docs
+
+src_prepare() {
+ # fix for sphinx >= 4.0
+ sed -e 's/PyModulelevel/PyFunction/g' \
+ -e 's/PyClassmember/PyClassMethod/g' \
+ -i sphinxcontrib/asyncio.py || die
+ default
}
python_install() {
@@ -32,7 +33,6 @@ python_install() {
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
# clean up pth files bug #623852
find "${ED}" -name '*.pth' -delete || die