summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-13 23:57:54 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-16 02:12:34 -0600
commit98103ab972312dbd80cd70d3262d5b21ca4e4896 (patch)
treeaea4aa308eab6258dd8f0d22235ee269a96d5474 /dev-python
parentdev-lang/ruby: enable ssl USE by default (diff)
downloadgentoo-98103ab972312dbd80cd70d3262d5b21ca4e4896.tar.gz
gentoo-98103ab972312dbd80cd70d3262d5b21ca4e4896.tar.bz2
gentoo-98103ab972312dbd80cd70d3262d5b21ca4e4896.zip
dev-python/multidict: version bump to 4.5.2
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/multidict/Manifest1
-rw-r--r--dev-python/multidict/multidict-4.5.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index 9dec4062a5c7..7af4a0ca31f6 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -7,3 +7,4 @@ DIST multidict-2.1.5.tar.gz 28497 BLAKE2B 301248a428f3be7740dd04ccc8ae5e92d97173
DIST multidict-3.3.2.tar.gz 40083 BLAKE2B 6622efd489d4f0046200b6b28a158306cff7a3e463688c512827b599500956793ac27f6ee839e076a921b84665bc932274a5ebf4c37e273fc02916dc9be1eed7 SHA512 d44c8b00ab7823b8840665aa1462ed547aea48874a408b2af8f1cb455727896cd77ef2201e8f234bcb3f2781599ffe931a5884fc55fc1f7286da29185c4d88fc
DIST multidict-4.1.0.tar.gz 43492 BLAKE2B 4d53a12896f070fd029816742ccff11a12636164e51215bb22b368da10d555d52a9ab7d5dc4632baec9ebc628ca4f846ad7fb2ad0bb044f033fd7e567cda0da8 SHA512 8972ca48146b40fd88f5b0675ed6d45e6887c31fc1d5962203f0fa77a369ef11b0d7739593f5691ae1fd2bbef989940983ddcf0c09acfc5a65b39b6b336571f9
DIST multidict-4.3.1.tar.gz 45342 BLAKE2B 12a0a8f0785c30e393d996c506a69d6ba03227e47040d46859e1289b47ce23b49a9bed48c3cb0b26f3bf4051cce3963d020a92ed28373038fb79b2204c13d380 SHA512 1b475836c776ddddfdc4f14882df41f9956ab06afac7b640e3f5ae3c50717f2b07267acbae2fa3e94cf8c5650273d4d7ce44329c0febea95046ee27d98db9288
+DIST multidict-4.5.2.tar.gz 56753 BLAKE2B 01db2ea847e5ef2fbd4eab89c8a6070f3febcb0046be7344469a7e8e6de6a3c2b2af49069e64953dfcac0044d581c6af09eee70eba78dda8cfa9e0d11d3f1947 SHA512 ec66cf3c57e3386e07e45641536a6eeb94e9707d8a0d3b485d22b8687f20282c9115d533c7b0e9fb6dba28b923cf68dd8cdda08c75e78ca4eca2f0c3ec23c58f
diff --git a/dev-python/multidict/multidict-4.5.2.ebuild b/dev-python/multidict/multidict-4.5.2.ebuild
new file mode 100644
index 000000000000..a2f8fb69a3f1
--- /dev/null
+++ b/dev-python/multidict/multidict-4.5.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_prepare_all() {
+ # don't use pytest-runner for tests
+ sed -i "s|'pytest-runner'||" setup.py || die
+
+ # don't enable coverage or other pytest settings
+ rm pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}