summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 12:05:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 12:07:06 +0200
commit991a4faf9c40aadcf0a6863903eafc403da759f4 (patch)
tree31564fd26f568dc26c8b365494c46ea25d241600 /dev-python
parentdev-python/dap: Remove last-rited pkg (diff)
downloadgentoo-991a4faf9c40aadcf0a6863903eafc403da759f4.tar.gz
gentoo-991a4faf9c40aadcf0a6863903eafc403da759f4.tar.bz2
gentoo-991a4faf9c40aadcf0a6863903eafc403da759f4.zip
dev-python/pastescript: Remove last-rited pkg
Closes: https://bugs.gentoo.org/719350 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pastescript/Manifest1
-rw-r--r--dev-python/pastescript/metadata.xml11
-rw-r--r--dev-python/pastescript/pastescript-2.0.2-r1.ebuild59
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/pastescript/Manifest b/dev-python/pastescript/Manifest
deleted file mode 100644
index 87aed62ec40f..000000000000
--- a/dev-python/pastescript/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST PasteScript-2.0.2.tar.gz 117521 BLAKE2B 2de72050ee7f5b7037b99f9661b5445e523607afc84a8846f0e5d9e89196e302627f552825ce0e4f821b7ed9ed2713c87d7b504a4e2abf092f1e8fa014c40c4b SHA512 2f093eb982972fed354219c75c2e008931cea553960cea8aaafbe57cde8556de5626e7eb9bb3b9b7328bad3b7d9899f11fc9773a65380396dae506e7531516de
diff --git a/dev-python/pastescript/metadata.xml b/dev-python/pastescript/metadata.xml
deleted file mode 100644
index f51d9da0abb6..000000000000
--- a/dev-python/pastescript/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">PasteScript</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pastescript/pastescript-2.0.2-r1.ebuild b/dev-python/pastescript/pastescript-2.0.2-r1.ebuild
deleted file mode 100644
index 0984831efdba..000000000000
--- a/dev-python/pastescript/pastescript-2.0.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-MY_PN="PasteScript"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
-HOMEPAGE="https://pypi.org/project/PasteScript/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/namespace-paste[${PYTHON_USEDEP}]
- >=dev-python/paste-1.3[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# Tests are broken.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- if use doc; then
- einfo "Generation of documentation"
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- nosetests -v -v || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use doc; then
- cd "${BUILD_DIR}"/sphinx/html || die
- dohtml -r [a-z]* _static
- fi
-
- find "${D}" -name '*.pth' -delete || die
-}