summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 13:14:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 13:29:25 +0100
commit99e8a93d029cb2370fb08397cdb6cd7b459b2353 (patch)
tree81a4fb98ee167ec0cf0dff361295f722a410e007 /dev-python
parentdev-python/pyzotero: Tested on py3.10 (diff)
downloadgentoo-99e8a93d029cb2370fb08397cdb6cd7b459b2353.tar.gz
gentoo-99e8a93d029cb2370fb08397cdb6cd7b459b2353.tar.bz2
gentoo-99e8a93d029cb2370fb08397cdb6cd7b459b2353.zip
dev-python/boto: Add py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto/boto-2.49.0-r4.ebuild3
-rw-r--r--dev-python/boto/files/boto-2.49.0-py310.patch44
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/boto/boto-2.49.0-r4.ebuild b/dev-python/boto/boto-2.49.0-r4.ebuild
index 113359bc0b19..5e32f2f4e2b1 100644
--- a/dev-python/boto/boto-2.49.0-r4.ebuild
+++ b/dev-python/boto/boto-2.49.0-r4.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${P}-py3-httplib-strict.patch
"${FILESDIR}"/${P}-py3-server-port.patch
"${FILESDIR}"/${P}-unbundle-six.patch
+ "${FILESDIR}"/${P}-py310.patch
)
RDEPEND=">=dev-python/six-1.12.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/boto/files/boto-2.49.0-py310.patch b/dev-python/boto/files/boto-2.49.0-py310.patch
new file mode 100644
index 000000000000..7b427f1f15e3
--- /dev/null
+++ b/dev-python/boto/files/boto-2.49.0-py310.patch
@@ -0,0 +1,44 @@
+diff --git a/boto/dynamodb/types.py b/boto/dynamodb/types.py
+index d9aaaa4c..3f8d8601 100644
+--- a/boto/dynamodb/types.py
++++ b/boto/dynamodb/types.py
+@@ -27,7 +27,7 @@ Python types and vice-versa.
+ import base64
+ from decimal import (Decimal, DecimalException, Context,
+ Clamped, Overflow, Inexact, Underflow, Rounded)
+-from collections import Mapping
++from collections.abc import Mapping
+ from boto.dynamodb.exceptions import DynamoDBNumberError
+ from boto.compat import filter, map, six, long_type
+
+diff --git a/boto/mws/connection.py b/boto/mws/connection.py
+index 687fae74..3a1f5f80 100644
+--- a/boto/mws/connection.py
++++ b/boto/mws/connection.py
+@@ -21,7 +21,7 @@
+ import xml.sax
+ import hashlib
+ import string
+-import collections
++import collections.abc
+ from boto.connection import AWSQueryConnection
+ from boto.exception import BotoServerError
+ import boto.mws.exception
+@@ -109,7 +109,7 @@ def http_body(field):
+ def destructure_object(value, into, prefix, members=False):
+ if isinstance(value, boto.mws.response.ResponseElement):
+ destructure_object(value.__dict__, into, prefix, members=members)
+- elif isinstance(value, collections.Mapping):
++ elif isinstance(value, collections.abc.Mapping):
+ for name in value:
+ if name.startswith('_'):
+ continue
+@@ -117,7 +117,7 @@ def destructure_object(value, into, prefix, members=False):
+ members=members)
+ elif isinstance(value, six.string_types):
+ into[prefix] = value
+- elif isinstance(value, collections.Iterable):
++ elif isinstance(value, collections.abc.Iterable):
+ for index, element in enumerate(value):
+ suffix = (members and '.member.' or '.') + str(index + 1)
+ destructure_object(element, into, prefix + suffix,