summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-08 23:23:52 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-08 23:49:46 +0200
commit9aed84eb66902114e12390499fae09bf4c846803 (patch)
treea7883f0afeb832804a5f44df9fc5c572a23406c9 /dev-python
parentnet-misc/libteam: keyword 1.31 for ~riscv (diff)
downloadgentoo-9aed84eb66902114e12390499fae09bf4c846803.tar.gz
gentoo-9aed84eb66902114e12390499fae09bf4c846803.tar.bz2
gentoo-9aed84eb66902114e12390499fae09bf4c846803.zip
dev-python/rencode: enable py3.10, fix deps+license, add tests
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rencode/files/rencode-1.0.6-drop-wheel-dependency.patch17
-rw-r--r--dev-python/rencode/rencode-1.0.6-r1.ebuild33
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/rencode/files/rencode-1.0.6-drop-wheel-dependency.patch b/dev-python/rencode/files/rencode-1.0.6-drop-wheel-dependency.patch
new file mode 100644
index 000000000000..1a7e0ea2b87a
--- /dev/null
+++ b/dev-python/rencode/files/rencode-1.0.6-drop-wheel-dependency.patch
@@ -0,0 +1,17 @@
+commit 3019171614f22c3d489d46e0fb22c07bf393830f
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun Aug 8 22:51:53 2021 +0200
+
+ Remove unnecessary wheel dependency
+
+diff --git a/setup.py b/setup.py
+index 023df09..6445c0a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -92,5 +92,5 @@ setup(
+ url="https://github.com/aresch/rencode",
+ cmdclass={'build_ext': optional_build_ext},
+ ext_modules=ext_modules,
+- setup_requires=['setuptools', 'wheel'],
++ setup_requires=['setuptools'],
+ )
diff --git a/dev-python/rencode/rencode-1.0.6-r1.ebuild b/dev-python/rencode/rencode-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..f02c970bbcdc
--- /dev/null
+++ b/dev-python/rencode/rencode-1.0.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="similar to bencode from the BitTorrent project"
+HOMEPAGE="https://github.com/aresch/rencode"
+SRC_URI="https://github.com/aresch/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/aresch/rencode/commit/16e61e1ff4294bddb7c881536d3d454355c78969
+ "${FILESDIR}/${P}-drop-wheel-dependency.patch"
+)
+
+python_test() {
+ # The C extension ("_rencode") can't be imported from "${S}/rencode"
+ # so we need to cd somewhere else to make sure "rencode" is imported
+ # from ${BUILD_DIR}/lib (thanks to PYTHONPATH).
+ cd "${T}" || die
+ epytest "${S}"
+}