summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-04 12:59:55 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-04 13:25:31 +0100
commit9b100dd2e49385ca84c64179cf35b77e460f170a (patch)
treedf0c69e01b028a32113044fbd1170e290bc79302 /dev-python
parentdev-python/ipython: Version Bump (diff)
downloadgentoo-9b100dd2e49385ca84c64179cf35b77e460f170a.tar.gz
gentoo-9b100dd2e49385ca84c64179cf35b77e460f170a.tar.bz2
gentoo-9b100dd2e49385ca84c64179cf35b77e460f170a.zip
dev-python/ipyparallel: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-5.0.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 4f66c2353644..4d02d6d6c59e 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1 +1,2 @@
DIST ipyparallel-4.1.0.tar.gz 2271608 SHA256 c943f6b3bbabb9332336d15474969e2a7a73d5b583f9786f7b357c75e4b1709a SHA512 19fff1ea57d9fcaec6525ce6e0c72ab63ab1245e32e485174a0691d2b48d8d2512af4055b77df82c7b30a8c071e1b6c5900d37e992f82f1597492e220e83d36f WHIRLPOOL ead35bc2166af0b221e730550689b09b7bf04148abcd754039f1c511acaa182ba50b593372f3e8bc627ae40a6117f9209cac476c1905bdc780f53de10666ffe1
+DIST ipyparallel-5.0.0.tar.gz 2286751 SHA256 ffa7e2e29fdc4844b3c1721f46b42eee5a1abe5cbb851ccf79d0f4f89b9fe21a SHA512 ef04b717198246300ad1020eb7f9a65c40553a897653384bd839d5fb05409a276df41f933b0f023c0523fc6d8cebf6e2c6f8478c8be4fe4fdf386ad78b8f4418 WHIRLPOOL 677fd7fa2090b2b75c234c4802fab553105d2e3ce44ab4c390cadc56ba5ff3814005ab478906197d6a9f862e0d69901168d22cdc44c8063cf8e71fc8f8bdc449
diff --git a/dev-python/ipyparallel/ipyparallel-5.0.0.ebuild b/dev-python/ipyparallel/ipyparallel-5.0.0.ebuild
new file mode 100644
index 000000000000..8bf04a1ec2f5
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-5.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ !<dev-python/ipython-4.0.0[smp]
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ iptest ipyparallel.tests -- -vsx || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}