summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-03-08 14:02:45 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-09 21:43:49 +0100
commit9bfccc1116405fcfc0e5538c85e6aa03ce9beafc (patch)
treed6daa0d7b8c3c44fd802cc17137dd70e2ae316b2 /dev-python
parentdev-python/nbdime: Drop old (diff)
downloadgentoo-9bfccc1116405fcfc0e5538c85e6aa03ce9beafc.tar.gz
gentoo-9bfccc1116405fcfc0e5538c85e6aa03ce9beafc.tar.bz2
gentoo-9bfccc1116405fcfc0e5538c85e6aa03ce9beafc.zip
dev-python/matplotlib2tikz: New package
matplotlib2tikz is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of matplotlib2tikz is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of matplotlib2tikz retains more information, can be more easily understood, and is more easily editable than raw TikZ output. Bug: https://bugs.gentoo.org/612052 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4161
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6-init_pipdated.patch15
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.2.ebuild25
-rw-r--r--dev-python/matplotlib2tikz/metadata.xml17
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
new file mode 100644
index 000000000000..1efb6a8c9999
--- /dev/null
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -0,0 +1 @@
+DIST matplotlib2tikz-0.6.2.tar.gz 26358 SHA256 a81b1a09e8c0efc9944d673023d3a8c14ca38aec04af487c427f20872555ff09 SHA512 b60f378f947ec51be82fc45dafad14ef2700babb2ec72886480aff9bd84d591bc15e0626f38018f2d351ab8293109b2fc12cc4912eb933528b5334b2ef8ecfb7 WHIRLPOOL befa7a990cc4246c2a3357c72b4c34ec76e44af905c0d19312eccbf5ce8e5c8742f906484214ab50466992ae3fed40c5ffbb84e8b80bb06cea830f892a9c947e
diff --git a/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6-init_pipdated.patch b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6-init_pipdated.patch
new file mode 100644
index 000000000000..2acf79738c0d
--- /dev/null
+++ b/dev-python/matplotlib2tikz/files/matplotlib2tikz-0.6-init_pipdated.patch
@@ -0,0 +1,15 @@
+Remove version checks using pipdated.
+
+Patch by Marius Brehler <marbre@linux.sungazer.de>
+--- a/matplotlib2tikz/__init__.py
++++ b/matplotlib2tikz/__init__.py
+@@ -15,9 +15,3 @@ from matplotlib2tikz.__about__ import (
+ )
+
+ from matplotlib2tikz.save import save
+-
+-import pipdated
+-if pipdated.needs_checking('matplotlib2tikz'):
+- msg = pipdated.check('matplotlib2tikz', __version__)
+- if msg:
+- print(msg)
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.2.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.2.ebuild
new file mode 100644
index 000000000000..e40f2b47df96
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${PN}-0.6-init_pipdated.patch" )
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
diff --git a/dev-python/matplotlib2tikz/metadata.xml b/dev-python/matplotlib2tikz/metadata.xml
new file mode 100644
index 000000000000..9c08eac0171c
--- /dev/null
+++ b/dev-python/matplotlib2tikz/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>matplotlib2tikz is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of matplotlib2tikz is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of matplotlib2tikz retains more information, can be more easily understood, and is more easily editable than raw TikZ output.</longdescription>
+ <upstream>
+ <remote-id type="github">nschloe/matplotlib2tikz</remote-id>
+ <remote-id type="pypi">matplotlib2tikz</remote-id>
+ </upstream>
+</pkgmetadata>