summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-03-19 23:08:05 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-03-19 23:08:05 +0700
commit9c036a0310995c4770f13f61a9be252751225464 (patch)
tree3957dc4423c97285f793fcce176a670f24ff48d6 /dev-python
parentdev-cpp/ms-gsl: Disable Werror when compiling tests (diff)
downloadgentoo-9c036a0310995c4770f13f61a9be252751225464.tar.gz
gentoo-9c036a0310995c4770f13f61a9be252751225464.tar.bz2
gentoo-9c036a0310995c4770f13f61a9be252751225464.zip
dev-python/pyx: fix a LaTeX problem with USE=doc
Bug: https://bugs.gentoo.org/604780 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyx/files/pyx-0.14.1-unicode-latex.patch10
-rw-r--r--dev-python/pyx/pyx-0.14.1-r1.ebuild49
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyx/files/pyx-0.14.1-unicode-latex.patch b/dev-python/pyx/files/pyx-0.14.1-unicode-latex.patch
new file mode 100644
index 000000000000..6495eb499b7c
--- /dev/null
+++ b/dev-python/pyx/files/pyx-0.14.1-unicode-latex.patch
@@ -0,0 +1,10 @@
+diff -r -U1 PyX-0.14.1.orig/faq/general_aspects_pyx.rst PyX-0.14.1/faq/general_aspects_pyx.rst
+--- PyX-0.14.1.orig/faq/general_aspects_pyx.rst 2015-11-02 23:19:54.000000000 +0100
++++ PyX-0.14.1/faq/general_aspects_pyx.rst 2018-03-19 16:45:16.432663630 +0100
+@@ -15,4 +15,4 @@
+ Despite the ties between TeX and PyX, their pronunciation is quite different.
+-According to the developers of PyX, it should be pronounced as [pʏks]. Please do
+-not pronounce it as [pʏx] or [pʏç].
++According to the developers of PyX, it should be pronounced as [pyks]. Please do
++not pronounce it as [pyx] or [pyç].
+
diff --git a/dev-python/pyx/pyx-0.14.1-r1.ebuild b/dev-python/pyx/pyx-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..eb92d512da11
--- /dev/null
+++ b/dev-python/pyx/pyx-0.14.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+MY_PN=PyX
+MY_P="${P/pyx/PyX}"
+DESCRIPTION="Python package for the generation of encapsulated PostScript figures"
+HOMEPAGE="https://pyx.sourceforge.net/
+ https://pypi.python.org/pypi/PyX/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="virtual/tex-base
+ dev-texlive/texlive-basic"
+
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ dev-python/sphinx[latex,${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${P}-unicode-latex.patch )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i \
+ -e 's/^build_t1code=.*/build_t1code=1/' \
+ -e 's/^build_pykpathsea=.*/build_pykpathsea=1/' \
+ setup.cfg || die "setup.cfg fix failed"
+}
+
+python_compile_all() {
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts
+ emake -C "${S}"/manual latexpdf
+ emake -C "${S}"/faq latexpdf
+ fi
+}
+
+python_install_all() {
+ use doc && dodoc manual/_build/latex/manual.pdf faq/_build/latex/pyxfaq.pdf
+ distutils-r1_python_install_all
+}