summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-29 13:34:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-29 13:55:46 +0200
commit9c727ea758bccfd5cc058c2990e01980e20449dc (patch)
tree660d8a8abe36cd7d7932ad2b3dd0cc02054ff621 /dev-python
parentmedia-video/simplescreenrecorder: Removed old (diff)
downloadgentoo-9c727ea758bccfd5cc058c2990e01980e20449dc.tar.gz
gentoo-9c727ea758bccfd5cc058c2990e01980e20449dc.tar.bz2
gentoo-9c727ea758bccfd5cc058c2990e01980e20449dc.zip
dev-python/falcon: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/falcon/Manifest1
-rw-r--r--dev-python/falcon/falcon-3.1.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/falcon/Manifest b/dev-python/falcon/Manifest
index 55051ca41e26..41ea3755b11f 100644
--- a/dev-python/falcon/Manifest
+++ b/dev-python/falcon/Manifest
@@ -1 +1,2 @@
DIST falcon-3.0.1.tar.gz 1300689 BLAKE2B 76dd59d0274cc2e78052b800e6e5b4c4244e1f5e47169a424882cda5bb59c38cd69c1c0942d506867728da9ddaf5d35b88195a1b003ca5f66549248293b7006d SHA512 c6a5763264b497979129df26d83a04323f53861b6d453a2b642d22208d0dad2ec1fcb88b13a53c2cb2b2988a1c0d19b94021099b458e23d640984b4d03880edc
+DIST falcon-3.1.0.tar.gz 1319252 BLAKE2B 183623c8d7e8b86ed9915cbf3757fd526f7f3a8a97ae5fdf86294bcc65052c5c827d4a920d93e9fa0198a8d255c7b56ecff465a36d9b0ea31581abd87d55ccd0 SHA512 9da76dd92dfce1611ef681588d8e0e2fc7e906b5c0bc4b60a4620e2e9907564783763b7776c9cc2ccb296116c985e527b2f429520a1c601567cf4eb15e98f8cc
diff --git a/dev-python/falcon/falcon-3.1.0.ebuild b/dev-python/falcon/falcon-3.1.0.ebuild
new file mode 100644
index 000000000000..121575f7c481
--- /dev/null
+++ b/dev-python/falcon/falcon-3.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A supersonic micro-framework for building cloud APIs"
+HOMEPAGE="
+ https://falconframework.org/
+ https://pypi.org/project/falcon/
+ https://github.com/falconry/falcon/
+"
+SRC_URI="
+ https://github.com/falconry/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ dev-python/cbor2[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # uwsgi seems to be broken/incompatible
+ 'tests/test_wsgi_servers.py::TestWSGIServer::test_get[uwsgi]'
+ 'tests/test_wsgi_servers.py::TestWSGIServer::test_get_deprecated[uwsgi]'
+ 'tests/test_wsgi_servers.py::TestWSGIServer::test_post_multipart_form[uwsgi]'
+ 'tests/test_wsgi_servers.py::TestWSGIServer::test_static_file[uwsgi]'
+ 'tests/test_wsgi_servers.py::TestWSGIServer::test_static_file_byte_range[uwsgi-'
+ )
+
+ local EPYTEST_IGNORE=(
+ # mujson is unpackaged, test-only dep
+ tests/test_media_handlers.py
+ )
+
+ rm -rf falcon || die
+ # needed because servers are spawned via /usr/bin/python*
+ local -x PYTHONPATH=${BUILD_DIR}/install$(python_get_sitedir):${PYTHONPATH}
+ epytest tests
+}