summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-25 07:57:50 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-25 07:59:23 -0500
commit9d74d38e49bb438dfff36fab754b0a1820c82e17 (patch)
treee2db1a2038d3b082820787f58dbf70d7b1f4b045 /dev-python
parentx11-wm/lumina: cleaning 1.4.0-r1 (diff)
downloadgentoo-9d74d38e49bb438dfff36fab754b0a1820c82e17.tar.gz
gentoo-9d74d38e49bb438dfff36fab754b0a1820c82e17.tar.bz2
gentoo-9d74d38e49bb438dfff36fab754b0a1820c82e17.zip
dev-python/simplejson: version bump to 3.13.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.13.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index b686110d4994..3e5e5455cf2e 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,3 +1,4 @@
DIST simplejson-3.10.0.tar.gz 77953 SHA256 953be622e88323c6f43fad61ffd05bebe73b9fd9863a46d68b052d2aa7d71ce2 SHA512 c8782fe434f3f1e29562092fe81f46fc272f0b83fdb3ca31fc03707fe09f4d30696ad7ec07a33de873bd08a41b19f97b9d09e3079658952e5110cf8f68eb53c6 WHIRLPOOL 53458b102f64e2fb841bf8c57b56bc0f9ded3d968eecad47ab184eb17be35ff2574ea8abe70867438e46f3f946afc17f7ef9cea3b66d300355e879531dfdafc1
DIST simplejson-3.11.1.tar.gz 78145 SHA256 01a22d49ddd9a168b136f26cac87d9a335660ce07aa5c630b8e3607d6f4325e7 SHA512 f4cdb6a77b39d099630e1774cf8bf33b9d138f69d4e766bfc70fb710e24ace00d7a92b4b30b3047e361212a030864055b9de4cc5f78d231cffd930284b209377 WHIRLPOOL d9d5e9e4fcecc8f11b334e48502b258016a09e4b794bdf91166f06f22dec1da78bdc1931f1e42eb5e3e843f49a1e2204dec7a3dc104871958107c22f96c81a44
DIST simplejson-3.12.0.tar.gz 77969 SHA256 df5e38f5e0a24abe0e02276aa5c3f8504150047a51c0b6b848b8153e6e6d395e SHA512 65b41f00a503ebdca169428aacac2f431e50099b6ac4c732cef769e17d3419d00f8ac40f9834d827a2f33391e6799d3af892e63e2a853ef1294b2ed8466bd7d8 WHIRLPOOL b319a7206544be28f3765c7c6a41111dc77d33e1937afd9df69e14d6a5b79b249390b10096a6c93289a79ce67756d80026aa8707a9069a02bfcab9bbad9d7247
+DIST simplejson-3.13.2.tar.gz 79735 BLAKE2B 5feb87611451054ad8e856e55a4a6bca50470f7f72692de9ce5abddf9eb214e29505124634d4d5a4f825366afe9a97614c66cbe14a73a4e57a5f2f62cac876e8 SHA512 ea29bc615de7fd0eb2a98f5dbeea74ee49b6fed6602396e77baf4480c86f975eff7fd868ac44f62a1c2f3721d4fa5b807b74109e5e28810df70dbad758110f41
diff --git a/dev-python/simplejson/simplejson-3.13.2.ebuild b/dev-python/simplejson/simplejson-3.13.2.ebuild
new file mode 100644
index 000000000000..63006c9caf2e
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.13.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}