summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-24 22:40:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-24 22:43:33 +0100
commit9daecf6a94d9385aa4866e4408688b4a7e608d8d (patch)
tree01b4cec4cee76f19db9ae7f611aded8f4bc00cc2 /dev-python
parentdev-python/pyfakefs: Bump to 4.4.0 (diff)
downloadgentoo-9daecf6a94d9385aa4866e4408688b4a7e608d8d.tar.gz
gentoo-9daecf6a94d9385aa4866e4408688b4a7e608d8d.tar.bz2
gentoo-9daecf6a94d9385aa4866e4408688b4a7e608d8d.zip
dev-python/markdown: Bump to 3.3.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-3.3.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index 84af96a722f0..63fb7a4fd48a 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -1,2 +1,3 @@
DIST Markdown-2.6.11.tar.gz 274132 BLAKE2B 0d14d308c97d925db83d71f3b9be5622e77ee4a159fced15c811390b39950e81bff9ffc567f32e878cbc44014640ab0a2f596258cfd0dce6b66029105cec7370 SHA512 4e7dd3e04f181fa2751a359aede301fb29a23b9af74867ff9d1d0fdd051dcd16d04a5891e37aff0b309649c5fd13363802ec7e10fc33896e9453991efcab4a66
DIST Markdown-3.3.3.tar.gz 319531 BLAKE2B b7a527a7d202ee955106ecddb75541285589cb006a0cb3e587f06bb06aa3be8bdf8e976a35cc2ca63b2f085a8b462f8e8d5fad84710561dc105e533939c04204 SHA512 b8e42c1471d155be6cc9aa0b6ce649454b09d36df1de51ef7e45043ae3c1c87b9b09e1fae4c680a771bee52e7fa8ea82548b78b2ffb1d38e85785f0b0de25b36
+DIST Markdown-3.3.4.tar.gz 322192 BLAKE2B 37122305112440b85d7f0e5e1bf90bafe15a8bcb84e8d8bdd9b4183dcb4be1010d287450062bab7dc9017d8e618f84a8245e6fd35f8204e5e2ece14d302fb13b SHA512 37422619dd8f542bfcf7975c92e76a39e4eeeb42386727d52037869cee1617f8efcb74a382a9c7cb903907ebf3643a27ba0de583bc0dbd327a36e72bbf8520af
diff --git a/dev-python/markdown/markdown-3.3.4.ebuild b/dev-python/markdown/markdown-3.3.4.ebuild
new file mode 100644
index 000000000000..2f439b137c6e
--- /dev/null
+++ b/dev-python/markdown/markdown-3.3.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc"
+
+# importlib_metadata is only necessary for <python:3.8 according to setup.py
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_{6,7} pypy3)
+"
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ use doc && dodoc -r docs/
+
+ distutils-r1_python_install_all
+}