summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-08-09 20:47:38 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-08-09 21:31:24 -0500
commit9e7a64ced6f5023e6dd20b19385546e7c87fb5b1 (patch)
tree15b454e0d71a979c2f8e3bb6f14d7882648a9908 /dev-python
parentdev-ruby/shotgun: treeclean (diff)
downloadgentoo-9e7a64ced6f5023e6dd20b19385546e7c87fb5b1.tar.gz
gentoo-9e7a64ced6f5023e6dd20b19385546e7c87fb5b1.tar.bz2
gentoo-9e7a64ced6f5023e6dd20b19385546e7c87fb5b1.zip
dev-python/*: treeclean last rited packages
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/contextlib2/Manifest2
-rw-r--r--dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild43
-rw-r--r--dev-python/contextlib2/contextlib2-21.6.0.ebuild24
-rw-r--r--dev-python/contextlib2/metadata.xml12
-rw-r--r--dev-python/linecache2/Manifest1
-rw-r--r--dev-python/linecache2/linecache2-1.0.0-r1.ebuild29
-rw-r--r--dev-python/linecache2/metadata.xml12
-rw-r--r--dev-python/pathlib2/Manifest2
-rw-r--r--dev-python/pathlib2/metadata.xml14
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild34
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.6.ebuild31
-rw-r--r--dev-python/traceback2/Manifest1
-rw-r--r--dev-python/traceback2/metadata.xml12
-rw-r--r--dev-python/traceback2/traceback2-1.4.0-r1.ebuild38
-rw-r--r--dev-python/unittest2/Manifest1
-rw-r--r--dev-python/unittest2/files/remove-argparse-dependence.patch12
-rw-r--r--dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch28
-rw-r--r--dev-python/unittest2/metadata.xml12
-rw-r--r--dev-python/unittest2/unittest2-1.1.0-r1.ebuild35
19 files changed, 0 insertions, 343 deletions
diff --git a/dev-python/contextlib2/Manifest b/dev-python/contextlib2/Manifest
deleted file mode 100644
index 4e2999596f23..000000000000
--- a/dev-python/contextlib2/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST contextlib2-0.6.0.post1.tar.gz 29670 BLAKE2B 927cbc674c2cb568e71bd110773bea6f848233928bb910e0db7114812b3359b9395e43c01be1645d44f3202f94c62bc21c4db883a155c64feb636a61865dd7d8 SHA512 bd3b458b365bc1d556476f6368bc523fde07e85afdad74037aa98d7a498008103a789f6b481b606700da92606ee6477fc5a817f1596e93a6e3c548ed0d4a5bf8
-DIST contextlib2-21.6.0.tar.gz 43795 BLAKE2B 52e62cf56bc11c0a0502d1d43ba361bea579af98a1c820afb73a6c2ab87bdf57317541cb7051b5aca05311ee2df24010e6e96c7ef4ee7192ec792cf2937aae68 SHA512 a85cafaaf66c7c6a59a4e9ac757941b1a98c17e5a49e41573dc759fafbbf17928a21f582e8aaa0fdc60636413ec702e198bde19a78ac304237b6da1c3d47b730
diff --git a/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild b/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild
deleted file mode 100644
index cae46e1d472e..000000000000
--- a/dev-python/contextlib2/contextlib2-0.6.0_p1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${PN}-${PV/_p/.post}"
-DESCRIPTION="Backports and enhancements for the contextlib module"
-HOMEPAGE="https://pypi.org/project/contextlib2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.4"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-
-DEPEND="
- test? ( $(python_gen_cond_dep '
- dev-python/unittest2[${PYTHON_USEDEP}]
- ' python2_7 pypy3
- )
- )
-"
-
-S="${WORKDIR}"/${MY_P}
-
-RESTRICT="!test? ( test )"
-
-DOCS=( NEWS.rst README.rst )
-
-python_prepare_all() {
- sed -i -e 's:unittest.main():unittest.main(verbosity=2):' \
- test_contextlib2.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" test_contextlib2.py || die "Tests fail for ${EPYTHON}"
-}
diff --git a/dev-python/contextlib2/contextlib2-21.6.0.ebuild b/dev-python/contextlib2/contextlib2-21.6.0.ebuild
deleted file mode 100644
index 1c336603c32c..000000000000
--- a/dev-python/contextlib2/contextlib2-21.6.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${PN}-${PV/_p/.post}"
-DESCRIPTION="Backports and enhancements for the contextlib module"
-HOMEPAGE="https://pypi.org/project/contextlib2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="PSF-2.4 Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DOCS=( NEWS.rst README.rst )
-
-distutils_enable_tests unittest
diff --git a/dev-python/contextlib2/metadata.xml b/dev-python/contextlib2/metadata.xml
deleted file mode 100644
index 9327abec758b..000000000000
--- a/dev-python/contextlib2/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">contextlib2</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/linecache2/Manifest b/dev-python/linecache2/Manifest
deleted file mode 100644
index 9b19afc7f799..000000000000
--- a/dev-python/linecache2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST linecache2-1.0.0.tar.gz 11013 BLAKE2B 5f9b125819d9c812d37f1c14ef9ab52f2d5787c83a3d0d891a4def65f17aea26d903b269a610b7247927f72c1594b434ce9274c5358b29799e4ca5b426b37836 SHA512 e585a6e4c054c1965bc4241a1e36b57cb04f32b2d778df0ae4381975700497975251f509354d3622e36c82973c726a207b815f8b12060d9d583b6669a9eb279e
diff --git a/dev-python/linecache2/linecache2-1.0.0-r1.ebuild b/dev-python/linecache2/linecache2-1.0.0-r1.ebuild
deleted file mode 100644
index aab01856e995..000000000000
--- a/dev-python/linecache2/linecache2-1.0.0-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Backports of the linecache module"
-HOMEPAGE="https://github.com/testing-cabal/linecache2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- dev-python/fixtures[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # eliminate unittest2 dep
- sed -i -e '/unittest/s:2 as.*::' linecache2/tests/test_linecache.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/linecache2/metadata.xml b/dev-python/linecache2/metadata.xml
deleted file mode 100644
index dfdeb6abf1bb..000000000000
--- a/dev-python/linecache2/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">linecache2</remote-id>
- <remote-id type="github">testing-cabal/linecache2</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pathlib2/Manifest b/dev-python/pathlib2/Manifest
deleted file mode 100644
index bf6172f630c0..000000000000
--- a/dev-python/pathlib2/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pathlib2-2.3.5.tar.gz 34393 BLAKE2B 7e03214a53f1ebf7718d04f653e24ffa4b06070b0ae21583d98ea0ce956c5aced5ea63bf6062d8e8d979bef4c82137cd2d2d5d6121dc3dda0ae1f713c1868d36 SHA512 3f0f212bf5208d0965ac02a590bef6ac0ec5e3b702828c06c3c9d37119b3db422cc7873de614fdc37ebfb3f52239a6517008d9672a176ca15d03fe13baeeddc8
-DIST pathlib2-2.3.6.tar.gz 38435 BLAKE2B 07a6db61feb56c439e0c4c97d96f87714090628d3971341b64ed253cf9b363b7a3695a665a3def5c2b950cd3dc2ba316ef3dcfaf48f25726fce34afedccdafac SHA512 ed41792338d5808cdd068f6c04021b2918e5376fc6297f163712dec6b00a1f96f7905eeea0a601c333d253e0f1663a0472d842b0d920d680992045bbc36db970
diff --git a/dev-python/pathlib2/metadata.xml b/dev-python/pathlib2/metadata.xml
deleted file mode 100644
index d8ee6f7bfb70..000000000000
--- a/dev-python/pathlib2/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">pathlib2</remote-id>
- <remote-id type="github">mcmtroffaes/pathlib2</remote-id>
- <bugs-to>https://github.com/mcmtroffaes/pathlib2/issues</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild b/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild
deleted file mode 100644
index 1719f9c6231b..000000000000
--- a/dev-python/pathlib2/pathlib2-2.3.5-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
-HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2)
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
- )
-"
-
-python_test() {
- "${EPYTHON}" tests/test_pathlib2.py -v || \
- die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/pathlib2/pathlib2-2.3.6.ebuild b/dev-python/pathlib2/pathlib2-2.3.6.ebuild
deleted file mode 100644
index ac123963984c..000000000000
--- a/dev-python/pathlib2/pathlib2-2.3.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
-HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-python_test() {
- "${EPYTHON}" tests/test_pathlib2.py -v ||
- die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/traceback2/Manifest b/dev-python/traceback2/Manifest
deleted file mode 100644
index 21597fa0d421..000000000000
--- a/dev-python/traceback2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST traceback2-1.4.0.tar.gz 15872 BLAKE2B cd2e1fe91e1e71a6dd764675e083857f359cfa5aaa3d2fee7f1709e24c545bb9e337f0af1d87f9e286fa2c36dfa12dca84589a936dc9f9805a1c4891739f337b SHA512 84c7fc291c8f2d4cee10441cdef1820aa453e631dfa91ed58e40fc205e97a9dd2101388d5689e4fdf10edfbf06bdb5b895d1635ae7218ba0c9b697d3f95f9342
diff --git a/dev-python/traceback2/metadata.xml b/dev-python/traceback2/metadata.xml
deleted file mode 100644
index 34b72c8f590a..000000000000
--- a/dev-python/traceback2/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">traceback2</remote-id>
- <remote-id type="github">testing-cabal/traceback2</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/traceback2/traceback2-1.4.0-r1.ebuild b/dev-python/traceback2/traceback2-1.4.0-r1.ebuild
deleted file mode 100644
index 764320ce82f6..000000000000
--- a/dev-python/traceback2/traceback2-1.4.0-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Backports of the traceback module"
-HOMEPAGE="https://github.com/testing-cabal/traceback2"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/linecache2[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]
- test? (
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # fails by line numbers on various py3 versions
- sed -i -e 's:test_context_suppression:_&:' \
- -e 's:test_format_locals:_&:' \
- -e 's:test_bad_indentation:_&:' \
- -e 's:test_encoded_file:_&:' \
- traceback2/tests/test_traceback.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/unittest2/Manifest b/dev-python/unittest2/Manifest
deleted file mode 100644
index d0ed1201801f..000000000000
--- a/dev-python/unittest2/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST unittest2-1.1.0.tar.gz 81432 BLAKE2B 02bf191baaa895689078e8f484bb368cd178ea2d1e275a5adcd3413eb25d18b9109c353046f60819c7ec26cd233867b7397e6e38004389aa928b4c53cfeb637c SHA512 3fba15728905f437767416ab4fd3573d3fb2319486ef84c52a9fa930ea84aa1f2ae29d6f58993e3509083625790e17b1ef8d9ac5de0e166c254897a3e7a202fa
diff --git a/dev-python/unittest2/files/remove-argparse-dependence.patch b/dev-python/unittest2/files/remove-argparse-dependence.patch
deleted file mode 100644
index 36f89fc5f8f6..000000000000
--- a/dev-python/unittest2/files/remove-argparse-dependence.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r 8928fb47c3a9 setup.py
---- a/setup.py Thu Mar 12 15:55:36 2015 +1300
-+++ b/setup.py Sun Apr 05 09:06:44 2015 -0500
-@@ -57,7 +57,7 @@
- # Both install and setup requires - because we read VERSION from within the
- # package, and the package also exports all the APIs.
- # six for compat helpers
--REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
-+REQUIRES = ['six>=1.4', 'traceback2'],
-
- params = dict(
- name=NAME,
diff --git a/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch b/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
deleted file mode 100644
index 4aae9d04b2f8..000000000000
--- a/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/unittest2/test/test_loader.py b/unittest2/test/test_loader.py
-index 683f662..347eea5 100644
---- a/unittest2/test/test_loader.py
-+++ b/unittest2/test/test_loader.py
-@@ -509,6 +509,7 @@ class Test_TestLoader(unittest2.TestCase):
- #
- # What happens when an impossible name is given, relative to the provided
- # `module`?
-+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
- def test_loadTestsFromName__relative_malformed_name(self):
- loader = unittest.TestLoader()
-
-@@ -811,6 +812,7 @@ class Test_TestLoader(unittest2.TestCase):
- # TestCase or TestSuite instance."
- #
- # What happens when presented with an impossible module name?
-+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
- def test_loadTestsFromNames__malformed_name(self):
- loader = unittest2.TestLoader()
-
-@@ -918,6 +920,7 @@ class Test_TestLoader(unittest2.TestCase):
- # "The method optionally resolves name relative to the given module"
- #
- # What happens when presented with an impossible attribute name?
-+ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
- def test_loadTestsFromNames__relative_malformed_name(self):
- loader = unittest.TestLoader()
-
diff --git a/dev-python/unittest2/metadata.xml b/dev-python/unittest2/metadata.xml
deleted file mode 100644
index 70f1765921a2..000000000000
--- a/dev-python/unittest2/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">unittest2</remote-id>
- <remote-id type="github">testing-cabal/unittest-ext</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild b/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
deleted file mode 100644
index 232865bfcf40..000000000000
--- a/dev-python/unittest2/unittest2-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="The new features in unittest backported to Python 2.4+"
-HOMEPAGE="https://pypi.org/project/unittest2/ https://github.com/testing-cabal/unittest-ext"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-RDEPEND="
- dev-python/linecache2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}"/remove-argparse-dependence.patch
- "${FILESDIR}"/${P}-python3.5-test.patch
-)
-
-python_test() {
- "${PYTHON}" -m unittest2 discover --verbose ||
- die "tests failed under ${EPYTHON}"
-}