summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-20 08:04:44 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-20 08:22:47 +0100
commit9fcf70cd81f4b84a2cc2acd18051fcfa96e60401 (patch)
tree8406f77d6bb207f70c42787d0d94fcc1e4944ef5 /dev-python
parentdev-ruby/ox: add 2.14.4 (diff)
downloadgentoo-9fcf70cd81f4b84a2cc2acd18051fcfa96e60401.tar.gz
gentoo-9fcf70cd81f4b84a2cc2acd18051fcfa96e60401.tar.bz2
gentoo-9fcf70cd81f4b84a2cc2acd18051fcfa96e60401.zip
dev-python/botocore: Bump to 1.20.33
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.33.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 448257679f64..0048fc650615 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -16,4 +16,5 @@ DIST botocore-1.20.29.tar.gz 7533728 BLAKE2B 75ca3262805177118d0f1a6060d98badf54
DIST botocore-1.20.30.tar.gz 7534280 BLAKE2B bfa6066e8e2c28475807b8a469257cc8fc6dfb17de231e25db411223a55bc897534e90aa2d7f2a89a21378f8dbbbae52e553333292c1726d11c60cfeea4f4f7a SHA512 3d0d2cc120a1aaa225ebbd2a9393e0d413653c44e55f99094f36d62993737a2f2b5d63a64225e207c4a21b60971fb40eb8c30059efe77cdad6681ce00d4da5ac
DIST botocore-1.20.31.tar.gz 7544090 BLAKE2B c8c158f69463e2eaf3c817d7577bd449724bf0a409e65bd83734cb7af3c0211999e4f7d240da97f017829ee04cbd4f69af0e7ea589adcfb413498dfd831630c9 SHA512 a7f8c02b4518a25e1eb0299b3cec5791810e81b7b6b1d8c9ef2e94cd9fcba21bdcdfc3fe96955e134fc0acb78e27aff850ee352a718d2bf518c8480287a1eb26
DIST botocore-1.20.32.tar.gz 7543258 BLAKE2B 464b1b32d32f25874cf73a57c281436a6c6095d69dbd90ac6566fbfacb58fea4162e61d58092708c243917398fb9c1898feb3ed7903515a0a2f24c6cf16278d3 SHA512 e7a7a1fac7fab4e6ec49e38909c306ed7f54b544ebe85cefb0a743aa44882707b51877d4872926be282117ecfeeef564f1345b2be8daed9cd54dcd970d5d6811
+DIST botocore-1.20.33.tar.gz 7543656 BLAKE2B eefd7b06c5a43780982616cfd640c6a1c5d9e919b403c0f78be06833e8e618b142cabacf2dd3b3e13cf351bbd5d0d42ef23b314355f68f7d9dc6aa9cae6e377f SHA512 6354ed7ebbe467ea96c0ea0e059acd2be0a40973d55998c0e006e73a67f2a69bd8009099f761af83e47022ad27698d3a21ffc2824ad4b74a687bc490239420e0
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.33.ebuild b/dev-python/botocore/botocore-1.20.33.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.33.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}