summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-08 20:10:56 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-08 20:41:20 +0100
commita229023e948f6beead1d89bcaa7e0ddea9165dbd (patch)
tree2a224b93427e3dbb269705b3f7a8cc210fbe5af7 /dev-python
parentdev-python/pypy-bin: Remove USE=doc (diff)
downloadgentoo-a229023e948f6beead1d89bcaa7e0ddea9165dbd.tar.gz
gentoo-a229023e948f6beead1d89bcaa7e0ddea9165dbd.tar.bz2
gentoo-a229023e948f6beead1d89bcaa7e0ddea9165dbd.zip
dev-python/pypy3: Remove commented out USE=doc logic
Remove the USE=doc logic since it was never fixed, and it was recently removed from dev-python/pypy.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3/pypy3-5.10.0.ebuild8
-rw-r--r--dev-python/pypy3/pypy3-9999.ebuild8
2 files changed, 2 insertions, 14 deletions
diff --git a/dev-python/pypy3/pypy3-5.10.0.ebuild b/dev-python/pypy3/pypy3-5.10.0.ebuild
index 8d3c3e165e4e..dcef9d5439d2 100644
--- a/dev-python/pypy3/pypy3-5.10.0.ebuild
+++ b/dev-python/pypy3/pypy3-5.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -45,7 +45,6 @@ DEPEND="${RDEPEND}
)
)
)"
-# doc? ( dev-python/sphinx )
S="${WORKDIR}/${MY_P}-src"
@@ -152,8 +151,6 @@ src_compile() {
cp -p "${T}"/usession*-0/testing_1/{pypy3-c,libpypy3-c.so} . || die
pax-mark m pypy3-c libpypy3-c.so
- #use doc && emake -C pypy/doc html
-
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.
@@ -230,9 +227,6 @@ src_install() {
"${ED%/}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
fi
- # Install docs
- #use doc && dohtml -r pypy/doc/_build/html/
-
einfo "Generating caches and byte-compiling ..."
local -x PYTHON=${ED%/}${dest}/pypy3-c
diff --git a/dev-python/pypy3/pypy3-9999.ebuild b/dev-python/pypy3/pypy3-9999.ebuild
index ff2a3ff800ed..c3217b6688dc 100644
--- a/dev-python/pypy3/pypy3-9999.ebuild
+++ b/dev-python/pypy3/pypy3-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -46,7 +46,6 @@ DEPEND="${RDEPEND}
)
)
)"
-# doc? ( dev-python/sphinx )
# Who would care about predictable directory names?
S="${WORKDIR}/pypy3-v${PV%_*}-src"
@@ -179,8 +178,6 @@ src_compile() {
cp -p "${T}"/usession*-0/testing_1/{pypy3-c,libpypy3-c.so} . || die
pax-mark m pypy3-c libpypy3-c.so
- #use doc && emake -C pypy/doc html
-
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.
@@ -258,9 +255,6 @@ src_install() {
"${ED%/}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
fi
- # Install docs
- #use doc && dohtml -r pypy/doc/_build/html/
-
einfo "Generating caches and byte-compiling ..."
local -x PYTHON=${ED%/}${dest}/pypy3-c