summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-27 11:17:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-27 12:29:05 +0300
commita29c3a7e0e76015c5749d048d4f8ddf895884157 (patch)
tree5b8809e21bdfcb0208bb5062a04b63aa531eda1a /dev-python
parentdev-python/nose2: enable py3.10 (diff)
downloadgentoo-a29c3a7e0e76015c5749d048d4f8ddf895884157.tar.gz
gentoo-a29c3a7e0e76015c5749d048d4f8ddf895884157.tar.bz2
gentoo-a29c3a7e0e76015c5749d048d4f8ddf895884157.zip
dev-python/flufl-testing: new NIH test dep of net-mail/mailman
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flufl-testing/Manifest1
-rw-r--r--dev-python/flufl-testing/flufl-testing-0.8.ebuild25
-rw-r--r--dev-python/flufl-testing/metadata.xml13
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/flufl-testing/Manifest b/dev-python/flufl-testing/Manifest
new file mode 100644
index 000000000000..017ec722019f
--- /dev/null
+++ b/dev-python/flufl-testing/Manifest
@@ -0,0 +1 @@
+DIST flufl.testing-0.8.tar.gz 8754 BLAKE2B 9465f3e1d98c324cac38b06b80d44d050a260d26dae9df5c59147284a0f0cf4c460a3d0048f834bf479c58eb7a631eefd4146a82d490552f6e46e7c9cd96fff2 SHA512 edf491db72cccafef58e08b810e4c29962d14716cda3318a892a3ca36095b95477e7564aa4fe8eb4f3bd7cd9e7896f82282dd2d3a67900932848f1dc265cea61
diff --git a/dev-python/flufl-testing/flufl-testing-0.8.ebuild b/dev-python/flufl-testing/flufl-testing-0.8.ebuild
new file mode 100644
index 000000000000..b2212bd8e62e
--- /dev/null
+++ b/dev-python/flufl-testing/flufl-testing-0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+
+DESCRIPTION="Small collection of test tool plugins"
+HOMEPAGE="https://gitlab.com/warsaw/flufl.testing https://pypi.org/project/flufl.testing/"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nose2[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/flufl-testing/metadata.xml b/dev-python/flufl-testing/metadata.xml
new file mode 100644
index 000000000000..27c3c91f4ce8
--- /dev/null
+++ b/dev-python/flufl-testing/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">flufl.testing</remote-id>
+ <remote-id type="gitlab">warsaw/flufl.testing</remote-id>
+ </upstream>
+</pkgmetadata>