summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-03 22:07:58 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-03 22:14:29 +0300
commita2eafae9142319746e1b876009d750845ea0dbba (patch)
treec44b768d938ab7a0350a9dbb338d5e6a8b68dd3a /dev-python
parentdev-python/pdm-pep517: add 1.0.1 (diff)
downloadgentoo-a2eafae9142319746e1b876009d750845ea0dbba.tar.gz
gentoo-a2eafae9142319746e1b876009d750845ea0dbba.tar.bz2
gentoo-a2eafae9142319746e1b876009d750845ea0dbba.zip
dev-python/hypothesis: add 6.48.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.48.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 0cf893b919a0..c5ae9bbf2d1b 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-6.48.2.gh.tar.gz 9316125 BLAKE2B a35fde81976dcc874897bb14cbb65f55b4c54f065ed84a69a6ff41274e35013acac404a2234577e9d9f9cc3674d1496102a356289fa3b8d0f1371d7da3d839ad SHA512 3c38941cb17b0a22e547a8da84821b0e83f70da3e4476e8865d91eea90dc0175782084dc2a02b17b8db7a9e177e076a7e4d4044f0cad86f2e658ae01a6be2775
+DIST hypothesis-6.48.3.gh.tar.gz 9316363 BLAKE2B 25e2e722d9c57902c62eff687959af340ebece8153b581acaee568bda965f635950fd8e2a304d687c69e57fafcb2f6ad7be69a7aad193119ac9766d659cc58ab SHA512 0bf8b2ded8567051dccb4651099ef4010dcb86b779ad2b765b0bd16e36ed7fa176f7698ec1c9cfa388f6de22c33c5c0d55b3168d43f9b940d1ba1bee3d930914
DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38bd62d2fe50ab929df075e253c059aed329d6b52051fb01449f8de84ae340ba42a4af94ef592411139a45d34aad232fe4bb2d8412165730bbeca01 SHA512 6fdd54f28d275eb65a4f6e6919437d503eba6254c25e22298c34ac67e6de03cd99a5178b1a475b1da7f7afeed8406e89c20b4818436143f442222d26f0d94796
DIST hypothesis-hypothesis-python-6.47.3.gh.tar.gz 9314739 BLAKE2B 282b012e020fc6494b628ba629c576f604db831c219878ab92539fbd1d980f3363e490ef35f888b68902661dd82e682393641d13a882c1177d8570ec232b217a SHA512 c7231ff06ae5846f718e76c48ed4bb8a1fc0f9aff80c7ddd1ff0ead219eb93dcc7f9d5c5e591390661e81a33bcac79773ea620cfe3f246210114635f0c089144
diff --git a/dev-python/hypothesis/hypothesis-6.48.3.ebuild b/dev-python/hypothesis/hypothesis-6.48.3.ebuild
new file mode 100644
index 000000000000..1065b755121f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.48.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}