summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 09:14:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 09:49:19 +0100
commita4961d7d494f49aa0caed1182d7ed41e719e2bf0 (patch)
tree9f7e76d3765d85f7f640943ec5e51dcf88325f9a /dev-python
parentdev-python/nbconvert: Bump to 6.4.1 (diff)
downloadgentoo-a4961d7d494f49aa0caed1182d7ed41e719e2bf0.tar.gz
gentoo-a4961d7d494f49aa0caed1182d7ed41e719e2bf0.tar.bz2
gentoo-a4961d7d494f49aa0caed1182d7ed41e719e2bf0.zip
dev-python/botocore: Bump to 1.23.44
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.23.44.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c6c6f199ff5d..a0b8861ff1e3 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.23.40.tar.gz 8730992 BLAKE2B 855742e6661e497c10cee6becbc9fc5eae3
DIST botocore-1.23.41.tar.gz 8732416 BLAKE2B 2d1a3284521a608db2dbfdbb8c98fb3bd01e048fb3b4a34e3dc497b6476bcbf8cd37ea9273ae3d3b09a9356aca8d1063dafdf15ae9c7ab59bbf3cc841bcc7a24 SHA512 d3d12df8faced36a9c7a75fd01d63986cb12d56a259f31211c32cbf0f1eceb1d6708e90f6a6a43189e37b86e01ceef68fcd5dcbd1867c571ca3630cbcc7e94f5
DIST botocore-1.23.42.tar.gz 8734201 BLAKE2B 009fd49716ce5a1453c83f279f36b8b174403ef7e403caa43a030126fde6e0e9bd414dc4369791aa090d7b10065906c6a97ada1d7796553af0cbbd4af8b78d95 SHA512 bc5ec5996fb139bc18975976bb8907978caf10399867cbcf8dc39bf47a5d61749c617c704cfbbe87074a6db5f4355f645fc88f06a71251c8bd3f65adacd1d9ba
DIST botocore-1.23.43.tar.gz 8739652 BLAKE2B 5520a9933ab87769c8459a0925822e36eba1741512bd11b575ba260ab0ea43aae66c737d66d3488aeb04cc10a2931af9136f7f80fc10bcdda309234de9bb6414 SHA512 51b11df7bf43a011df904e92285ecc373888e42e3d7e349e47df42c78432a60f692ccfbeb01fc598f9d81861823578a3cc1798340196468ee3e30de7e6a9dd03
+DIST botocore-1.23.44.tar.gz 8741781 BLAKE2B e76dcbf7a57421e4df3afa9317a1fcc66c0f7e00a3112384537daafb349648e38ec7cc6fb4b808fbfe69a6c6cfd30f04bbefb7fcc246d2b647ea4fc78aa17378 SHA512 59562e8ef5e18465a1981c188a84112326ab5f7d7ed4f72eacea3a88d43d615c8b3514d7bf6a2daf92ac29dc8bb24f8f878c318c8f463cd1ceb7e237f18dfc26
diff --git a/dev-python/botocore/botocore-1.23.44.ebuild b/dev-python/botocore/botocore-1.23.44.ebuild
new file mode 100644
index 000000000000..79a1cd5da0e2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.23.44.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit}
+}