summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-02 08:59:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-02 17:12:15 +0200
commita540847441dbe4a6de3eff54c20c8a50378abd19 (patch)
treeef56ec630e361f06ba495095f216efd1c8d8327e /dev-python
parentdev-python/fuse-python: Bump to 1.0.4 (diff)
downloadgentoo-a540847441dbe4a6de3eff54c20c8a50378abd19.tar.gz
gentoo-a540847441dbe4a6de3eff54c20c8a50378abd19.tar.bz2
gentoo-a540847441dbe4a6de3eff54c20c8a50378abd19.zip
dev-python/websockets: Bump to 9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/websockets-9.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index 3e7658935440..4cd17ad3d109 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1 +1,2 @@
DIST websockets-8.1-src.tar.gz 156472 BLAKE2B 6cb5eec8276f7ef7172048eba6157560f42cec28acacc1a0a2f426ea1cab9a04029ebb1f8285b1aa2862c30aac8f2af81ef85d4dba8e53e267b665b718e01d5a SHA512 d245702574cf513da54bfc0ca10768558cd4e5017ecf8cb647f4b9176561192a3ace64edfc5c6f735664bf1b6136aa0bb9828114478f92d2c051e3109a218c12
+DIST websockets-9.0-src.tar.gz 192076 BLAKE2B f5d2fe0e947b4833a11c013ce64640369794e1c5e4db5dcee7a630d8edd46ba72afd4bc42cd8adb392c09e2758d907a0029e09d61465215b3fbaa2430582cf2f SHA512 446d9734e2767a19a5c84de2676cf3730dc717d94e14443ded01727d47b02fca67546bcebe37d177088baaee61c8a7a90f7e15df1ee5bd0ed0a96bb4e46ad1d8
diff --git a/dev-python/websockets/websockets-9.0.ebuild b/dev-python/websockets/websockets-9.0.ebuild
new file mode 100644
index 000000000000..0992a9e2d617
--- /dev/null
+++ b/dev-python/websockets/websockets-9.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="https://github.com/aaugustin/${PN}/archive/${PV}.tar.gz -> ${P}-src.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+distutils_enable_tests unittest