summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-16 13:36:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-16 13:40:53 +0300
commita95dacdfe88772197375f1af44220b69c25c3b00 (patch)
tree6ec90bbb80485057f7e242800dfa926534929a4c /dev-python
parentapp-cdr/cdrtools: arm stable wrt bug #723346 (diff)
downloadgentoo-a95dacdfe88772197375f1af44220b69c25c3b00.tar.gz
gentoo-a95dacdfe88772197375f1af44220b69c25c3b00.tar.bz2
gentoo-a95dacdfe88772197375f1af44220b69c25c3b00.zip
dev-python/leather: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/leather/leather-0.3.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/leather/leather-0.3.4-r1.ebuild b/dev-python/leather/leather-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..50d619012db8
--- /dev/null
+++ b/dev-python/leather/leather-0.3.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python charting for 80% of humans"
+HOMEPAGE="https://github.com/wireservice/leather https://pypi.org/project/leather/"
+SRC_URI="https://github.com/wireservice/leather/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme