summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-20 06:42:53 +0000
committerSam James <sam@gentoo.org>2021-11-20 06:42:53 +0000
commita9a3566f532b65a95141b1e5a9f013cb5c3df009 (patch)
tree5eaeca72d69a1f071d269c9bdb1e5189e210e827 /dev-python
parentdev-python/patsy: Keyword 0.5.2 hppa, #804136 (diff)
downloadgentoo-a9a3566f532b65a95141b1e5a9f013cb5c3df009.tar.gz
gentoo-a9a3566f532b65a95141b1e5a9f013cb5c3df009.tar.bz2
gentoo-a9a3566f532b65a95141b1e5a9f013cb5c3df009.zip
dev-python/pytables: skip some known-failing tests on big endian
Use Debian's patch for this. Bug: https://bugs.gentoo.org/805995 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch36
-rw-r--r--dev-python/pytables/pytables-3.6.1-r1.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch b/dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch
new file mode 100644
index 000000000000..6a492a1a581f
--- /dev/null
+++ b/dev-python/pytables/files/pytables-3.6.1-big-endian-tests-skip-subset.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/805995
+https://github.com/PyTables/PyTables/issues/735
+https://sources.debian.org/src/pytables/3.6.1-5/debian/patches/0005-Skip-index-backcompat-tests-on-bingendian.patch/
+
+From: Antonio Valentino <antonio.valentino@tiscali.it>
+Date: Sat, 3 Aug 2019 16:22:13 +0000
+Subject: Skip index backcompat tests on bingendian
+
+Forwarded: not-needed
+--- a/tables/tests/test_index_backcompat.py
++++ b/tables/tests/test_index_backcompat.py
+@@ -6,8 +6,10 @@ from tables.tests.common import verbose
+ from tables.tests.common import unittest, test_filename
+ from tables.tests.common import PyTablesTestCase as TestCase
+
++import sys
+
+ # Check indexes from PyTables version 2.0
++@unittest.skipIf(sys.byteorder != 'little', 'broken on big-endian')
+ class IndexesTestCase(common.TestFileMixin, TestCase):
+
+ def setUp(self):
+@@ -145,11 +147,13 @@ class IndexesTestCase(common.TestFileMixin, TestCase):
+
+
+ # Check indexes from PyTables version 2.0
++@unittest.skipIf(sys.byteorder != 'little', 'broken on big-endian')
+ class Indexes2_0TestCase(IndexesTestCase):
+ h5fname = test_filename("indexes_2_0.h5")
+
+
+ # Check indexes from PyTables version 2.1
++@unittest.skipIf(sys.byteorder != 'little', 'broken on big-endian')
+ class Indexes2_1TestCase(IndexesTestCase):
+ h5fname = test_filename("indexes_2_1.h5")
+
diff --git a/dev-python/pytables/pytables-3.6.1-r1.ebuild b/dev-python/pytables/pytables-3.6.1-r1.ebuild
index b9fcf11be120..bcad8167a71a 100644
--- a/dev-python/pytables/pytables-3.6.1-r1.ebuild
+++ b/dev-python/pytables/pytables-3.6.1-r1.ebuild
@@ -49,6 +49,7 @@ DOCS=( RELEASE_NOTES.txt THANKS )
PATCHES=(
"${FILESDIR}"/${P}-numpy-float.patch
"${FILESDIR}"/${P}-py310.patch
+ "${FILESDIR}"/${PN}-3.6.1-big-endian-tests-skip-subset.patch
)
python_prepare_all() {