summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-22 20:46:24 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-22 20:47:37 -0800
commitaa487ca65ad88e1922013197c91bde9912626614 (patch)
treeee9abc2468bad9e52515f7fd5955c167161597cc /dev-python
parentapp-text/qpdf: Stabilize 10.5.0 hppa, #833736 (diff)
downloadgentoo-aa487ca65ad88e1922013197c91bde9912626614.tar.gz
gentoo-aa487ca65ad88e1922013197c91bde9912626614.tar.bz2
gentoo-aa487ca65ad88e1922013197c91bde9912626614.zip
dev-python/paho-mqtt: Version bump to 1.6.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/paho-mqtt/Manifest1
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index 7deb8bf07d47..94c0c0ebade8 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1 +1,2 @@
DIST paho-mqtt-1.6.0.tar.gz 145605 BLAKE2B 8f8dfba1c57520793041221e470258a644a0e5c9d462244615f7d7481d1ef8ef4d3209ea9664c4f34bcd70f07addd7fbfbe5857853339b02a266ad2e43acbf90 SHA512 06a18a83b6743c816b4323324c78906ea8937366424d2c3aab3eac565dff040254f1384500cee9cff60d3931131b9f6298ae24795eaff486b03fc998140ece72
+DIST paho-mqtt-1.6.1.tar.gz 145673 BLAKE2B fb583a2505892370737edfc9ad06b195c0feda4fd87794f3aa40fb30679b5710e04483e610a6be9c0e0978084f3ca96c0d285cf8cacb2bf67aca605f1d53ed7c SHA512 8a13c1f6f97138728d5cab6f7bcd6474942fdf9dfc18d1fad723d50de81f4e062953b5bef2ebbde27b08e480eed305ecbfeae467d70eb10f07ec0adca11750ec
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild
new file mode 100644
index 000000000000..42851e9557cc
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for MQTT v5.0, v3.1.1, and v3.1"
+HOMEPAGE="https://www.eclipse.org/paho/index.php?page=clients/python https://github.com/eclipse/paho.mqtt.python"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+LICENSE="EPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ ) "
+
+distutils_enable_tests pytest