summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-07-17 20:00:35 +0200
committerMarek Szuba <marecki@gentoo.org>2020-07-17 22:09:49 +0200
commitabefb268fbf3edd5b402357c8f1d2449d68dfebf (patch)
treee0e2768bf4f24f68eea4024e8ef01eb80bc3a0b7 /dev-python
parentdev-python/css-parser: PYTHON_COMPAT+="python3_9" (diff)
downloadgentoo-abefb268fbf3edd5b402357c8f1d2449d68dfebf.tar.gz
gentoo-abefb268fbf3edd5b402357c8f1d2449d68dfebf.tar.bz2
gentoo-abefb268fbf3edd5b402357c8f1d2449d68dfebf.zip
dev-python/pytools: update the live ebuild
Bump EAPI version to 7, sync PYTHON_COMPAT with the latest release, use distutils_enable_tests. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytools/pytools-9999.ebuild27
1 files changed, 7 insertions, 20 deletions
diff --git a/dev-python/pytools/pytools-9999.ebuild b/dev-python/pytools/pytools-9999.ebuild
index 765b22bf080c..618ec9fc5a6d 100644
--- a/dev-python/pytools/pytools-9999.ebuild
+++ b/dev-python/pytools/pytools-9999.ebuild
@@ -1,37 +1,24 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE='sqlite'
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1 git-r3
-DESCRIPTION="A collection of tools missing from the Python standard library"
+DESCRIPTION="Collection of tools missing from the Python standard library"
HOMEPAGE="https://mathema.tician.de/software/pytools/"
EGIT_REPO_URI="https://github.com/inducer/pytools"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
>=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.8.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- >=dev-python/setuptools-0.7.2[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
+ >=dev-python/six-1.8.0[${PYTHON_USEDEP}]"
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest