summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-16 03:20:30 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-16 03:20:30 +0200
commitacb8ba0f5cb508eca7a0554800c3cd7d6574b913 (patch)
treea450fff2bae64ccb52f60d2bde83c47979215f4f /dev-python
parentapp-emulation/docker-registry: Version bump to 2.6.1 (diff)
downloadgentoo-acb8ba0f5cb508eca7a0554800c3cd7d6574b913.tar.gz
gentoo-acb8ba0f5cb508eca7a0554800c3cd7d6574b913.tar.bz2
gentoo-acb8ba0f5cb508eca7a0554800c3cd7d6574b913.zip
dev-python/pytz: Version bump to 2017.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2017.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index 3e1e0bb74f90..7cab9cd71180 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -2,3 +2,4 @@ DIST pytz-2015.6.tar.bz2 156925 SHA256 01eed1b2226dc386d8e467a2ff8c4f1aa08c65d5d
DIST pytz-2016.10.tar.bz2 172920 SHA256 7016b2c4fa075c564b81c37a252a5fccf60d8964aa31b7f5eae59aeb594ae02b SHA512 a571dc035d713b05e1fe5760ddbb7701492c78b2faf38455ffc147c1d68fcee8d6f2d43a9d12724561ee2b1ddd83526d6ac44629c35899080f22a13abe854346 WHIRLPOOL a896e2c46e17891ab7455082003716e891e8916b5a3e3c0d776b4af7e17479c861537c4ae3a232f3288bd3302bd556261e4c81fe2ce72e0bcd179dd187722145
DIST pytz-2016.3.tar.bz2 170906 SHA256 c193dfa167ac32c8cb96f26cbcd92972591b22bda0bac3effdbdb04de6cc55d6 SHA512 8d91a84500257327361a8ccd19ce2d2e5848c10c7d4105ec1be012be592ec38113611558c7894c1825cc1967303901fce35079fc799cc10e84216864cd00266f WHIRLPOOL b2af20a788fa70c23b04cda3acdff812c30713f00a9aaf2144d85c64341f6fe4e365b558f3f0b5491c6c99ebf633d2d3910c95f7a6ae1f9c53b40da6bcbc23af
DIST pytz-2016.7.tar.bz2 170973 SHA256 6eab31709e3a4aea748457707da45e805b650cbb352583805d2417de2a1dd71e SHA512 2c7d4691a0f49c732c8fe97f0df70b7ce4d7b8bb6c1d3db590dce78152cac46443cf5900d38d35472d92b2b8ef3654e0f67066279a7a1d357eac24d334501f3b WHIRLPOOL f286cd1cf735f1fe12aadafd4567ba037d81a88749fbf34d78052d20c80b5d6fca676fc43c35250bb935b3c3a5497d64ac1bc9af99d86bd2f911874d807bd2e7
+DIST pytz-2017.2.zip 502168 SHA256 f5c056e8f62d45ba8215e5cb8f50dfccb198b4b9fbea8500674f3443e4689589 SHA512 d67d64a64b4c21e0bd41da56020fc7b016aec9da7f3243f79b65704119f70b8a9cd4f5f905631b6761e06ecef93830e5e479e16c7b1611ac70e0cd2b39d5b916 WHIRLPOOL 3a8e5e0c71ba12c8083592582238a17c1db862c1f779e84b4e93dbdadf9f5445d11d7725bc40f8d340569d2374adbf0ef19886c595f2d766a3dd7c57742cda44
diff --git a/dev-python/pytz/pytz-2017.2.ebuild b/dev-python/pytz/pytz-2017.2.ebuild
new file mode 100644
index 000000000000..7da38c7b7a24
--- /dev/null
+++ b/dev-python/pytz/pytz-2017.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="http://pythonhosted.org/pytz/ https://pypi.python.org/pypi/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || ( >=sys-libs/timezone-data-2016j sys-libs/glibc[vanilla] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/2016.6.1-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2009h-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${PYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}