summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 13:30:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 13:35:40 +0200
commitad2a3197a296818d7620a29de394dea63cbd8d49 (patch)
treef66670b9adcdb39f925640ec2177db1304ed730b /dev-python
parentdev-python/restructuredtext-lint: Enable py3.9 & py3.10 (diff)
downloadgentoo-ad2a3197a296818d7620a29de394dea63cbd8d49.tar.gz
gentoo-ad2a3197a296818d7620a29de394dea63cbd8d49.tar.bz2
gentoo-ad2a3197a296818d7620a29de394dea63cbd8d49.zip
dev-python/ropemode: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ropemode/ropemode-0.5.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/ropemode/ropemode-0.5.ebuild b/dev-python/ropemode/ropemode-0.5.ebuild
index eb540c46a0a4..52d9fc458cb5 100644
--- a/dev-python/ropemode/ropemode-0.5.ebuild
+++ b/dev-python/ropemode/ropemode-0.5.ebuild
@@ -1,28 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# Currently (2020-11-04) rope is blocking
-# support for python 3.9.
-# For details see
-# https://github.com/python-rope/rope/issues/299
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="A helper for using rope refactoring library in IDEs"
HOMEPAGE="https://github.com/python-rope/ropemode https://pypi.org/project/ropemode/"
SRC_URI="https://github.com/python-rope/ropemode/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# pypi releases don't include tests
-#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/rope[${PYTHON_USEDEP}]"
+BDEPEND="test? ( ${RDEPEND} )"
python_test() {
- "${PYTHON}" ropemodetest.py || die "tests failed with ${EPYTHON}"
+ "${PYTHON}" ropemodetest.py -v || die "tests failed with ${EPYTHON}"
}