summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 06:47:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 08:05:26 +0200
commitad80c58cf57d8d938e78dca89fe44487915dcc73 (patch)
tree8aab1e3f376011771d32597c219a42b348fac954 /dev-python
parentdev-ruby/elasticsearch: add github upstream metadata (diff)
downloadgentoo-ad80c58cf57d8d938e78dca89fe44487915dcc73.tar.gz
gentoo-ad80c58cf57d8d938e78dca89fe44487915dcc73.tar.bz2
gentoo-ad80c58cf57d8d938e78dca89fe44487915dcc73.zip
dev-python/botocore: Bump to 1.31.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 8f5e95664a01..565a96e57d96 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,3 +7,4 @@ DIST botocore-1.29.165.gh.tar.gz 11734461 BLAKE2B 30a479dfbc1e19c08baf38e5140a54
DIST botocore-1.30.0.gh.tar.gz 11743386 BLAKE2B 5117ae44f7b70dcf82e319fce1f72cba9291c7557144b410640b9ae727de0c4d31b7d896fd4d730b06a02f3ebd4341f208b84cc432a4aacf040b119ed2836923 SHA512 b1d3237949300e44eb29d3e4a14d3069cac75ad2da115d3c3e261605b7e9e7951402bf804b5055c33ce3e91a7c3c6b936ec4429e34f8b0d76ea61f1b804195c8
DIST botocore-1.30.1.gh.tar.gz 11745235 BLAKE2B 07813b701ddde0e0ece703bb64abb9b0e8d15228f0db82756b4dc705ab97ebbfd10823cf1c279600d70a1e7caa15824cf34a108580b240c6a21d7760373f9e12 SHA512 4701b45541acbbe0d667c82db90f408bc50e28c4c8de0b6b90c8923ea8a159cf868b15eddbdaeac651ecc8f0829cff454723ba2f313a99f3878e818b0416ca64
DIST botocore-1.31.0.gh.tar.gz 11756795 BLAKE2B 8a9299570aa5da4d9195e52bb2b3772ffbd7946ac269ecf46510818fbbd1b62c285cc01d6ffdbed8eb70cd0d4ab4f5624de30e2517e809e0d7546dfd15fa0262 SHA512 05b31e2a8bd63c483dee6e9d4d8865235e8465e827c6f372d06cb794352c1f691c12823b3d8e1c8107366628fe43a45881a05cd1ef54b68ce579a4f2ce4bddda
+DIST botocore-1.31.1.gh.tar.gz 11766144 BLAKE2B b55fc719e47e38523b8c674fd709697a42ee661354deec8c3d1a9c16c536b640775794c310a1274354ef5d3d494bbb42cd01f82c05a2e7244415e474a19e3146 SHA512 a02a888453c7fff24f8e33d201d2b7fa745b60c3a7a327ffeb213f963ded10848e8fbfe3de0bd6e3926c23fed10a72cc1ef4ee54f6d3ece0752ae84a22cb061e
diff --git a/dev-python/botocore/botocore-1.31.1.ebuild b/dev-python/botocore/botocore-1.31.1.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}