summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-08 08:16:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-08 08:33:19 +0200
commitae10aaa88cf77da5b2a5e415c52f00a0512cbc9e (patch)
tree01666a566d8f76bad5157243834bde81cff51397 /dev-python
parentdev-python/hypothesis: Bump to 6.14.6 (diff)
downloadgentoo-ae10aaa88cf77da5b2a5e415c52f00a0512cbc9e.tar.gz
gentoo-ae10aaa88cf77da5b2a5e415c52f00a0512cbc9e.tar.bz2
gentoo-ae10aaa88cf77da5b2a5e415c52f00a0512cbc9e.zip
dev-python/immutables: Bump to 0.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/immutables/Manifest1
-rw-r--r--dev-python/immutables/immutables-0.16.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
index 2683945fd16c..7f80750bbb7b 100644
--- a/dev-python/immutables/Manifest
+++ b/dev-python/immutables/Manifest
@@ -1 +1,2 @@
DIST immutables-0.15.tar.gz 81297 BLAKE2B cb58142c3b833d529046f09a468b3e3964e3d36e4eaf0825f88b920e6795cd042e2fc837ea6d72000bbc9cbc2fd1de911e08b4f6d189e692748b49e848dfb3fb SHA512 cd0ee20f6d6218eaf13499e40971b6750009ff01a1aefcb7dd45c77ae841296b9d9184013e6e7fe5bdef93587f85cdb8ff459af29424a0077538666260572b8e
+DIST immutables-0.16.tar.gz 84916 BLAKE2B e699aaa1135fa9f7db9589276dc0801a67c5f98bd3c5b247913d8263f9baf02a8772d7715cc3eb2c9392694d48d3808d50f45e9fe8e66c4d507586d0e3fdc319 SHA512 5b883cfe43f8a042b617e719dccd3cbdded3b1d1df160ba26b6bb2f0816a7171698bdd2ba3d450e76f135b236e777052a22c09b8bd1a9183227f1ccc90617cf8
diff --git a/dev-python/immutables/immutables-0.16.ebuild b/dev-python/immutables/immutables-0.16.ebuild
new file mode 100644
index 000000000000..a384f3130478
--- /dev/null
+++ b/dev-python/immutables/immutables-0.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://github.com/MagicStack/immutables"
+SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/mypy/d' tests/conftest.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # force running from BUILD_DIR to get the C extension tested
+ cp -r tests "${BUILD_DIR}"/lib || die
+ cd "${BUILD_DIR}"/lib || die
+ epytest tests --ignore tests/test_mypy.py
+ rm -r tests || die
+}