summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-03 06:05:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-03 06:05:43 +0200
commitaeebec5a87ed6486ceeb65fcd51e0a71ed1ef124 (patch)
treec0814b534e0b319427ce49f63975720909394dc3 /dev-python
parentdev-python/pytest-shell-utilities: Bump to 1.8.0 (diff)
downloadgentoo-aeebec5a87ed6486ceeb65fcd51e0a71ed1ef124.tar.gz
gentoo-aeebec5a87ed6486ceeb65fcd51e0a71ed1ef124.tar.bz2
gentoo-aeebec5a87ed6486ceeb65fcd51e0a71ed1ef124.zip
dev-python/inflect: Bump to 6.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-6.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index 4d4fd5b5fcb4..d941fa7bfba6 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1 +1,2 @@
DIST inflect-6.0.4.tar.gz 71131 BLAKE2B 24ec6f25462594fde4558f7a4269c68d31989ead54c982f3a4382b5f0c192fd5fcac7544413fecef0abaf7c3fe2f9b4a8049fc7dc7d324e4397fb6a81763ef8e SHA512 96aaa74b3e8c5dcc91d81af336af73535826f3cedaa556d6baf540ca54db1a7c1f17a372c240446c0d81697520eab154bad4f0aad6195c6ab8e131ae443d3811
+DIST inflect-6.1.0.tar.gz 71080 BLAKE2B a4f86fa3d64f979ad184d3744dd40c5a220ea904bef3cc87af3f675febdd1346b918797a879ebee368f4d9381e698476229b538fe15f14921c41351450132a04 SHA512 2457ed594081a3f26390e88b5d5826867cd3d54ffd73c4cfe52c20cac873157ec64e30ff3e01efebb0b1edf8b0e412930bae434e1cd8c7920a273667d5e6eb68
diff --git a/dev-python/inflect/inflect-6.1.0.ebuild b/dev-python/inflect/inflect-6.1.0.ebuild
new file mode 100644
index 000000000000..c6247d69eeb2
--- /dev/null
+++ b/dev-python/inflect/inflect-6.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ <dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.9.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest