summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-01-23 14:50:49 +0100
committerFabian Groffen <grobian@gentoo.org>2019-01-23 14:52:38 +0100
commitafcb332f66e7b072b37e04472e80f93bd8979c55 (patch)
tree2ce9553ef6a08df0047b803a4694c0663025f896 /dev-python
parentdev-python/whisper: version bump (diff)
downloadgentoo-afcb332f66e7b072b37e04472e80f93bd8979c55.tar.gz
gentoo-afcb332f66e7b072b37e04472e80f93bd8979c55.tar.bz2
gentoo-afcb332f66e7b072b37e04472e80f93bd8979c55.zip
dev-python/carbon: version bump
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/carbon/Manifest1
-rw-r--r--dev-python/carbon/carbon-1.1.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
index e52499e0f8d8..0725ce242462 100644
--- a/dev-python/carbon/Manifest
+++ b/dev-python/carbon/Manifest
@@ -2,3 +2,4 @@ DIST carbon-0.9.13.tar.gz 47509 BLAKE2B 0f967d81846139164278b99aa31237c8065b7d60
DIST carbon-0.9.14.tar.gz 50285 BLAKE2B e7926bf81509b9f65ff31287c4149102c4e249896df5035f4e18cf791e50800dff4974c49ab663f0ea5fcdee27301696a026c57ba49c1cd9b113b55f3fe97480 SHA512 e70275c0acce17287b3036668e45c75b9da9b54523faca0f5bdceda4b6b98c71ebf773740e85063ee3ea4e0bc64adee913bb7f8eab1f7016eb504b06f0b589e3
DIST carbon-0.9.15.tar.gz 50321 BLAKE2B c3cda5251bfab2c968c3538c25178cebcd4c98436c5b939d663d64f597e60236f69a01ad7f1427dda45db8c7c2e79fd625cb33513cf3e7c5dbc53b00fce2bb15 SHA512 e8ed8ac9b247d0f5bbe0331de50d929f918ee7968ad5053d2532f4d09e49215eaecae95a79f6b8360aa0f73fc7e68a73d86886e0329b3f5ccb569136658f6562
DIST carbon-1.1.3.tar.gz 68824 BLAKE2B b5e532fa0d0d8dc8ab8c3c555dea6bb3b918cd5b516ea4c754f9b3cd37230f54b63d202cfead9ec4242ebf78031c2671050354dccccde2980c4101b9699b1393 SHA512 0cfa9260484de147660110b7d2cc7e41bcbd7751c80bd5c557534b2a52c2183fdba94d40f8654fe54f593b2ab34581b2480e96c8a6dde4d47de783153a2cbe65
+DIST carbon-1.1.5.tar.gz 72365 BLAKE2B 304e515fd3cae806e141d0a76983d13967885a7e57c310d86c0c83560aa306a573676fb0135fceccf14cc7ed42d8a9dcb7869ab0d6ac3b2fc00c2fb088011873 SHA512 1b3a0a0d4005e2ec8d5bca062b41f0e18329c1bc4d3a4b3eca5e8f7c94c20387281392eefceaca90294e51860eabecca242c487068433119f1f249f8659ed560
diff --git a/dev-python/carbon/carbon-1.1.5.ebuild b/dev-python/carbon/carbon-1.1.5.ebuild
new file mode 100644
index 000000000000..08cf9a435f2f
--- /dev/null
+++ b/dev-python/carbon/carbon-1.1.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} ) # 3.7 dropped due to dep-hell
+
+inherit distutils-r1
+
+DESCRIPTION="Backend data caching and persistence daemon for Graphite"
+HOMEPAGE="http://graphite.wikidot.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+
+# whisper appears to have been missed from listing in install_requires in setup.py
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ dev-python/txAMQP[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Do not install the configuration and data files. We install them
+ # somewhere sensible by hand.
+ sed -i -e '/data_files=install_files,/d' setup.py || die
+ # We want FHS-style paths instead of /opt/graphite
+ export GRAPHITE_NO_PREFIX=yes
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/carbon
+ doins conf/*
+
+ keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
+
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
+ newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
+
+ newconfd "${FILESDIR}"/carbon.confd carbon-cache
+ newconfd "${FILESDIR}"/carbon.confd carbon-relay
+ newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
+}
+
+pkg_postinst() {
+ einfo 'This ebuild installs carbon into FHS-style paths.'
+ einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
+ einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
+ einfo '(see /etc/carbon/carbon.conf.example).'
+ einfo ' '
+ einfo 'OpenRC init script supports multiple instances !'
+ einfo 'Example to run an instance b of carbon-cache :'
+ einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
+ einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
+}