summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-05-21 16:54:53 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-05-21 16:54:53 +0200
commitb018ba0ae6bd6596455dd69939f9b3fa5e93de35 (patch)
tree82c90553baa93da0bbfe1415d676bcbded63d023 /dev-python
parentsys-kernel/vanilla-kernel: permit arm & arm64 (diff)
downloadgentoo-b018ba0ae6bd6596455dd69939f9b3fa5e93de35.tar.gz
gentoo-b018ba0ae6bd6596455dd69939f9b3fa5e93de35.tar.bz2
gentoo-b018ba0ae6bd6596455dd69939f9b3fa5e93de35.zip
dev-python/ws4py: fix $S
Closes: https://bugs.gentoo.org/723188 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ws4py/ws4py-0.5.1-r1.ebuild7
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild9
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
index 558868593e60..3e590bb7984c 100644
--- a/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1-r1.ebuild
@@ -10,13 +10,16 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)?"
+MY_PN="WebSocket-for-Python"
+
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
+ EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 arm ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
fi
DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 21de5cde42da..3e590bb7984c 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -10,13 +10,16 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+)?"
+MY_PN="WebSocket-for-Python"
+
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
+ EGIT_REPO_URI="https://github.com/Lawouach/${MY_PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="https://github.com/Lawouach/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 arm ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
fi
DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"