summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-17 14:31:59 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-17 14:33:26 +0200
commitb0a04442ea0540f5de45d6db6461e5730bc7bda0 (patch)
treeb3b9671f8a719fd8c89a34cbee2bcd128013b901 /dev-python
parentdev-python/redis-py: add 4.1.1 (diff)
downloadgentoo-b0a04442ea0540f5de45d6db6461e5730bc7bda0.tar.gz
gentoo-b0a04442ea0540f5de45d6db6461e5730bc7bda0.tar.bz2
gentoo-b0a04442ea0540f5de45d6db6461e5730bc7bda0.zip
dev-python/pytest-asyncio: add 0.17.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.17.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 5b7c50d0ddc2..7f85589cae1d 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,2 +1,3 @@
DIST pytest-asyncio-0.16.0.tar.gz 15819 BLAKE2B c999b8680a45704bcb6f4690a910aa3d2edd9965e53cf4eb59dc8119696add4553d6b3e1b010c3cac52c8fd8563be8c86afe0616132a274e73df673630b032a7 SHA512 f0059a6d05bf0c4e208f0058e30d5baf8284e630b8b91fa217f52eec18abe6b057dabfdadce2c5282e02bd4ea4cdb27f9ef62c4c308375cce1795d75a036db22
DIST pytest-asyncio-0.17.0.tar.gz 22275 BLAKE2B 0151b7e264b2c2435735bdc184020b6997d20b0ed82224b0b528ec366ab7554a0282619c5268d92f2544d700bed2dbaf85adaaf1752e333c417cc044bffb6aac SHA512 cfff79cf0632153819c511d3751777858e87081b074bfb49f3fe49417d1be647b4d07a4b64149acec36b4e6b1872ac03f1055703c70cccce18648482c9b727db
+DIST pytest-asyncio-0.17.1.tar.gz 23694 BLAKE2B 30856f9635db84fade650c1ecebe9c713d8cd801acd646e3dffb97996c591e4a11378faba8abe30002a1fa0f6dc62aae53029f059504478d4527e88c404929c2 SHA512 691bedb0d84e05179815d9a5c11108568dc59fc8fe6e8549e54e14b83e5e6bcad37d512980ea27f87f927f623c0496bbddf0aff1f44fc78f9bea1d9106b0800c
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.17.1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.17.1.ebuild
new file mode 100644
index 000000000000..eba2bcf7d5c3
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.17.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/modes/test_legacy_mode.py
+)