summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-16 13:11:47 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-16 14:40:22 +0200
commitb376b2b620be7611b50e9e8f9801fde8fcf454d0 (patch)
tree9690e5b059a9842f5ecbf2010295ad8e3f79f012 /dev-python
parentdev-python/cryptography-vectors: Bump to 2.0.3 (diff)
downloadgentoo-b376b2b620be7611b50e9e8f9801fde8fcf454d0.tar.gz
gentoo-b376b2b620be7611b50e9e8f9801fde8fcf454d0.tar.bz2
gentoo-b376b2b620be7611b50e9e8f9801fde8fcf454d0.zip
dev-python/cryptography: Bump to 2.0.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-2.0.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 088d0ff31e1f..a35e54d7cc3a 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -3,3 +3,4 @@ DIST cryptography-1.7.2.tar.gz 420867 SHA256 878cb68b3da3d493ffd68f36db11c29deee
DIST cryptography-1.8.1.tar.gz 423560 SHA256 323524312bb467565ebca7e50c8ae5e9674e544951d28a2904a50012a8828190 SHA512 273c8ca4ad6c9d1151a8a731d148d02e619e14e37df25dc26030b0a90f895b88fbf4d3e320aec5ea7af4a8fcc58f720c61f48968f912c69156d4e0e794743345 WHIRLPOOL ff760c9dc7dfbba355afde726a9154bcf45102e135b95b431aab5ac34c8003edccafa646b51ca02296aa55f244b0ff752d8d1b775cb76a1c9f15d347d505e8ce
DIST cryptography-1.9.tar.gz 409664 SHA256 5518337022718029e367d982642f3e3523541e098ad671672a90b82474c84882 SHA512 815e9c09366935f8603a3e6e74c28ce79175596d00dbcd19d3792505237bd1cf953a4f401c2b97e4beaa7f2bbdcf9d7f95c4753d001a07fa816830af97cdd24e WHIRLPOOL b79a10de82b2cf98b27535f0b018f651038ed235f5e63eed48da52a87efaf672057e147b9c1b23701da0505d52cc85558ad3b6e692670a9f9e63061b381500d8
DIST cryptography-2.0.2.tar.gz 427303 SHA256 3780b2663ee7ebb37cb83263326e3cd7f8b2ea439c448539d4b87de12c8d06ab SHA512 a71219ff52006a7c8bf1553d0f132c747566c630281ef89aac40c65b193b1f0074fc9cda1de7057c76b452113dfb6188c83baef3ed9c05ff18adbc8b7bba646b WHIRLPOOL 2c3b3da3d2d578c0ba29230c0955fd48688fd5039f08eacefc4017c5cd357d1096cdc79a271ff4e7319c1bb344edee12f8c184c33f12569226612a4dccfb6d11
+DIST cryptography-2.0.3.tar.gz 427544 SHA256 d04bb2425086c3fe86f7bc48915290b13e798497839fbb18ab7f6dffcf98cc3a SHA512 fa569c4f5a994e2bd90810649fdf48115bfd5ff46790c849991e8f7a7c8b5435402f92453e4365426ee645623b3bb509c9bb781657c4b4e81e3a36b58ba5461c WHIRLPOOL 4bbbfb4c57a5c4de7c84654d6474bd9b7b0d1eb9ed1f63d91a360b2987187f7bb1910ff4ca540b37fd3e98a00b37d5963a92b2d6ae0acfaab1636f512e887ca3
diff --git a/dev-python/cryptography/cryptography-2.0.3.ebuild b/dev-python/cryptography/cryptography-2.0.3.ebuild
new file mode 100644
index 000000000000..963e8c1c16d1
--- /dev/null
+++ b/dev-python/cryptography/cryptography-2.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist(-)] )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}