summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-07-30 00:24:50 -0700
committerZac Medico <zmedico@gentoo.org>2017-07-30 00:36:53 -0700
commitb38b516c382d7eec24526325e3eac25e9f347b57 (patch)
tree276e966c874ccdf69682d650765438284f13c894 /dev-python
parentdev-python/namespace-google: Add pypy to PYTHON_COMPAT (diff)
downloadgentoo-b38b516c382d7eec24526325e3eac25e9f347b57.tar.gz
gentoo-b38b516c382d7eec24526325e3eac25e9f347b57.tar.bz2
gentoo-b38b516c382d7eec24526325e3eac25e9f347b57.zip
dev-python/google-auth: version bump to 1.0.1
* Add namespace support (bug 626350) Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/google-auth/Manifest2
-rw-r--r--dev-python/google-auth/google-auth-1.0.1.ebuild (renamed from dev-python/google-auth/google-auth-1.0.0.ebuild)12
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 04adfd4a1506..3be448476273 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1 +1 @@
-DIST google-auth-1.0.0.tar.gz 66514 SHA256 9cec5a1e8161e5074a54af66f0f2ebf2cbdcc4aad1ffaa804589c3029695fa6a SHA512 7826bab85a68109f8118a28a1b9e5e4a5c0953ee1dae8f8ba266fefed4c949d0a20680fd0b3019f137c2d9b2d350825cf6679db110238808e7e5bca49704d6bf WHIRLPOOL 4b422bc70ad34a40135c1400aa7b7c45029ab420c16ba499f12a421585b4e0d45562458183f8e4f7a0027f312ce8d8cf5da3f4d0ffb65fe6381a1f0a75fc806e
+DIST google-auth-1.0.1.tar.gz 133903 SHA256 dd7b6e5f3bd15c0f7cfee63a266acea40c779da0a924b475bc1812e6e10687e1 SHA512 c10822c6b75700503a06a4b3a43a123d57605a043eb494bcb0232cc3941fc039d0803ed75be26d0da72fd4df613135c290fb3fdf82b0fa47d4fe0729462d80f4 WHIRLPOOL 04560bf31278988be1c98c0d781b84cfbc48b3c1e00e772ca83d17cbf05d2db055e6a8bf732605d39cdc02a0068d898b3c5765019e2550cdc980f2da50cd222e
diff --git a/dev-python/google-auth/google-auth-1.0.0.ebuild b/dev-python/google-auth/google-auth-1.0.1.ebuild
index 13d08d473455..26c40b5bf9a5 100644
--- a/dev-python/google-auth/google-auth-1.0.0.ebuild
+++ b/dev-python/google-auth/google-auth-1.0.1.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
inherit distutils-r1
DESCRIPTION="Google Authentication Library"
-HOMEPAGE="https://pypi.python.org/pypi/google-auth/ "
+HOMEPAGE="https://pypi.python.org/pypi/google-auth/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
@@ -17,6 +17,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
>=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
@@ -38,5 +39,12 @@ python_prepare_all() {
}
python_test() {
- py.test -v || die "Tests failed under ${EPYTHON}"
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
}