summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-03-22 11:01:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-03-22 11:03:38 -0500
commitb4856a0ca82200682be798b914c05b4c8ee5e6f4 (patch)
treedf8930ba22f82bee2e4852005ab3d3dc89815aa3 /dev-python
parentdev-python/ddt: arm64 keywording (diff)
downloadgentoo-b4856a0ca82200682be798b914c05b4c8ee5e6f4.tar.gz
gentoo-b4856a0ca82200682be798b914c05b4c8ee5e6f4.tar.bz2
gentoo-b4856a0ca82200682be798b914c05b4c8ee5e6f4.zip
dev-python/python-ironicclient: 1.11.1 bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ironicclient/Manifest1
-rw-r--r--dev-python/python-ironicclient/python-ironicclient-1.11.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/python-ironicclient/Manifest b/dev-python/python-ironicclient/Manifest
index 0d4bd33c5701..b1e302e56ba1 100644
--- a/dev-python/python-ironicclient/Manifest
+++ b/dev-python/python-ironicclient/Manifest
@@ -1,2 +1,3 @@
DIST python-ironicclient-0.9.0.tar.gz 95562 SHA256 8de88260f30625c6eb8c38fa3401945b510485e00189edaa18ca745b738f6a9a SHA512 324aec8ed9861ce2df4b7783b7bd8b98e30efbc8775ddcb4668f760d8916248df0d32def5cb2d30e9e743ff30e5b6717c653ca6e5cb9ea25b536a369ac45be5d WHIRLPOOL 8d992fff69724706b0a2becf84fd2312bba9be59e7b7103f39a0d5905553d9926510ae6dedd28c4f8ed51c179ddfa2cee97f78c7d2cdc59bb86b8b2fd9cb75de
+DIST python-ironicclient-1.11.1.tar.gz 171255 SHA256 0d278cfe3892ed22bd63b727868566f05717550faaef0710c7614d0ddb66ea0b SHA512 d8f164ad46a7fd3d3fd9a11e44384f1acb52b0ce9b4567b08a7e59d32e2098678c74afd2025689df1f0959d72072308867fec57ee0a9e14ba8ea33ec4ca8cbe6 WHIRLPOOL 31abf58bc482487cd419ffde4e43512ebd6a3b40262c612a57b2d1f0f8d3bc2ef54bdab94aa04915fc2a7dd96fea83d2ed290ff7792d3f39174efe2876524d23
DIST python-ironicclient-1.7.1.tar.gz 147835 SHA256 826f318061205ead8c597c17d7384260c8e685c9538d8e10d7791a18a04750ed SHA512 65d94f745c9544805bd73f77dcdc7f0ab731f932a01629089a952af6f30b85d1db38f518cd4e82ec0346c13dbcaf1eb0e4e166b28d940c77fcbb57ae2465ac08 WHIRLPOOL e911ddda35aef0aa6481fe8a62ca518df0f4e7311a2890a4504fb58f939f6a18cf77890ad29ad2a76501d2be62178f9cdda0d8b6ef5eccd1d86b9290a846f76d
diff --git a/dev-python/python-ironicclient/python-ironicclient-1.11.1.ebuild b/dev-python/python-ironicclient/python-ironicclient-1.11.1.ebuild
new file mode 100644
index 000000000000..1291d045ccce
--- /dev/null
+++ b/dev-python/python-ironicclient/python-ironicclient-1.11.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Ironic API"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+"
+CRDEPEND="
+ >=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ ${CRDEPEND}
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ dev-python/doc8[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ ${CRDEPEND}
+"
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/^tempest/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ #rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}