summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-29 09:42:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-29 09:46:53 +0200
commitb58eb400e3097e4425390497cbfb23752448b821 (patch)
tree917636c2560cc02b4479d4800c6e0636ee97ea93 /dev-python
parentnet-libs/libiscsi: bump up to 10.19.0 (diff)
downloadgentoo-b58eb400e3097e4425390497cbfb23752448b821.tar.gz
gentoo-b58eb400e3097e4425390497cbfb23752448b821.tar.bz2
gentoo-b58eb400e3097e4425390497cbfb23752448b821.zip
dev-python/jaraco-collections: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 1bb0db854f2a..a8d7d189ff04 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-3.2.0.tar.gz 18195 BLAKE2B 51510dd5053563319eac1c412deadac0a5f99ce3144d44150b5835ab92a05529998676fdcb577a5e725b19b4953c47c662e2f3eaa791de955c2493014713dd11 SHA512 cfea2de312781ec9d7a51752570432ec85e62834d02582023378ce0815e0c25f4d4e6afad8486559aa4e3f6fa6e602df917fdb11ed7a72423bea7ae816675258
+DIST jaraco.collections-3.3.0.tar.gz 18563 BLAKE2B 80e8463324598cdd6025984c6ab304b108521a606de87fa7aeacbb2234aec5fce20319d7cd288caa5a46b1fefb7e7686a2d00e668e90c38b943082267e6b4ceb SHA512 23fea645226bcfbd5f034877aff7846960ad99d65d451bdbf5b8abb166356074d07780ea8e2e25d31fd03343929596dcd64a9ec949c1ff056c11862e043a8b7e
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
new file mode 100644
index 000000000000..337b892d43db
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
+)
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest