summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-05-15 21:10:43 +0100
committerMichał Górny <mgorny@gentoo.org>2018-05-16 09:26:17 +0200
commitb688802d6003565005bdfcde765cf40e94401f86 (patch)
treeec502210501e1532efe803324bf4985242ffc6af /dev-python
parentdev-util/abi-compliance-checker: Bump to 2.3 (diff)
downloadgentoo-b688802d6003565005bdfcde765cf40e94401f86.tar.gz
gentoo-b688802d6003565005bdfcde765cf40e94401f86.tar.bz2
gentoo-b688802d6003565005bdfcde765cf40e94401f86.zip
dev-python/libcloud: add new version 2.3.0
Cloned from 1.5.0 ebuild. Changes: * added "|| die" as needed * stopped using EXAMPLES var which is banned since EAPI=6 * upgraded EAPI to 7 * dropped old cryptic comment "py3 dropped due to failing tests..." Closes: https://github.com/gentoo/gentoo/pull/8399 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libcloud/Manifest1
-rw-r--r--dev-python/libcloud/libcloud-2.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index 7ec75e74f377..c854c5a27305 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -1,3 +1,4 @@
DIST apache-libcloud-0.15.1.tar.bz2 570953 BLAKE2B 1baca706ac57d76baf4f83824ea0fccaccec51f38114a0103777e2965e67ad9cd96ad46459841ea702d72f8f0c3ce166037714d04f91c1f2369ddf6f455ffa63 SHA512 0cbc02c955cb91e135d73a5198ad216d0f91fa942b88dd1ffc1c46a487190f45500f003d2825cdb4f6c96c4ca7e5cf2681709769b0c2d8801b08e5a41b3d69b0
DIST apache-libcloud-1.2.1.tar.bz2 992983 BLAKE2B e3caccd2814f3b25fa96fbc21972fb3694a6f5e55663564f712b98b64a60e577baf1da0295b914fef2440a461f6fa16f313e83bde252360ac6786995527afc04 SHA512 12e239f286d8eb523597488998582be02d6e8cd4e21a8fa7c639c829ba622833e4292ac4cd7cbc8b94670e19ec1711cb0032bc72433f421bf2ba2b8c70dcd954
DIST apache-libcloud-1.5.0.tar.bz2 1258553 BLAKE2B 9cad0f61ab8505deea99c15022da92caf24295480d16bedf9c735c1117a055c94162cdcb331734c572f375de3ba10b499d5ed46a5a11f1e634d272e69748ef79 SHA512 91c10d164f56c9f75c6e5633802c3cf31046ab7a3ae554b73310b1da2d882ac1f8e90aaf3462db57ac0949dfd66cb840ec8fc6e6b79c46128668f13183d47b30
+DIST apache-libcloud-2.3.0.tar.bz2 1370556 BLAKE2B 14c6604d190d63f9049de2034b487cd7bb314add399339cac7a46dcbfea339497ede0d8058fd29dab43d53a45637fc5e60c71a5079fff6f45ed5023721eb68f2 SHA512 673c5b7b12f4510f2b43ea8199fab1e3f7ded62423d7d67301f5e3448c78750bc898c494a33d033844acf94bc292582371e9ac02ce1db6f4443a3966ef9fd0e8
diff --git a/dev-python/libcloud/libcloud-2.3.0.ebuild b/dev-python/libcloud/libcloud-2.3.0.ebuild
new file mode 100644
index 000000000000..93bc7ecbd443
--- /dev/null
+++ b/dev-python/libcloud/libcloud-2.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="https://libcloud.apache.org/"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python{2_7,3_4} pypy)
+ )"
+
+# Known test failures
+RESTRICT="test"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}