summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-02 21:29:35 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-02 21:29:35 -0700
commitb767a1041a9587db2c50a847eef2c68a94393633 (patch)
treea8bc4bc1be6b63b11d542b455bb7f377eae04a60 /dev-python
parentdev-python/psutil: version 5.2.2 (diff)
downloadgentoo-b767a1041a9587db2c50a847eef2c68a94393633.tar.gz
gentoo-b767a1041a9587db2c50a847eef2c68a94393633.tar.bz2
gentoo-b767a1041a9587db2c50a847eef2c68a94393633.zip
dev-python/ldap3: version bump to 2.2.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ldap3/Manifest1
-rw-r--r--dev-python/ldap3/ldap3-2.2.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ldap3/Manifest b/dev-python/ldap3/Manifest
index 6f373eaa8029..b4d6da4deb27 100644
--- a/dev-python/ldap3/Manifest
+++ b/dev-python/ldap3/Manifest
@@ -1 +1,2 @@
DIST ldap3-1.4.0.tar.gz 300079 SHA256 f69cb30894423b31b44206fa0548f2bf38cb5afc527f6c1a6e90f6c9327ef901 SHA512 0aaa05355dd065f66a6fb24ce298f8b632f013ffa47e805b0a1674ba96e89554106a437d8a6fceece36ccb84484e447595f459697baba9a432c458c9969f0da6 WHIRLPOOL 1d5fb8d91411f5ad90fcf8e70093c3da9533902212051df648facc776a81fd8a31ceffc2d5714e25cca62696bb5d82667bff98c843aa308ef549ce45a9b51133
+DIST ldap3-2.2.3.tar.gz 331483 SHA256 28ec651fbe5822cbd4161a96ccaad5b1b5c4adba186addc1232d94f2e6b03c23 SHA512 a954f6c582e88addf0bd6dc6fb24108d76d134b80c14a3dca0f9f667dbbfee484cb7b0444822f7e82a41af7dacf61ba111b6dcbf215b7f6df26a3784cfd2fc83 WHIRLPOOL e38f149d3218a61c1de4b8b0f25eeffcb936900f8a189b37dcc77131db854dd36d5b97213f0d36e22f8017ff9e14c975240e6d064b544780bd4f3c994a99970a
diff --git a/dev-python/ldap3/ldap3-2.2.3.ebuild b/dev-python/ldap3/ldap3-2.2.3.ebuild
new file mode 100644
index 000000000000..35f3ea68309b
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ nosetests -v -s test || die
+}